aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iproute2/iproute2_2.6.34.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-15 07:19:54 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-15 07:22:26 -0700
commit4dd5818c12c4b6c1efdba5812adcc61d0dcc6ae1 (patch)
tree5cd2084936371dae3d7e3c53f33012ac89c3e81e /recipes/iproute2/iproute2_2.6.34.bb
parent9b54b9315e2507b3fa835449e9a5e8aa31a369ff (diff)
downloadopenembedded-4dd5818c12c4b6c1efdba5812adcc61d0dcc6ae1.tar.gz
iproute2_2.6.34: Make configure to honor cross environment.
* The configure is hand made and it calls gcc directly to poke for stuff which is not correct when build in cross enviroment so change gcc calls to $CC and pass the sysroot as a parameter to search libraries in correct sysroot and not in /usr/lib or /lib Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/iproute2/iproute2_2.6.34.bb')
-rw-r--r--recipes/iproute2/iproute2_2.6.34.bb12
1 files changed, 9 insertions, 3 deletions
diff --git a/recipes/iproute2/iproute2_2.6.34.bb b/recipes/iproute2/iproute2_2.6.34.bb
index fb84cb1285..9f8acfe191 100644
--- a/recipes/iproute2/iproute2_2.6.34.bb
+++ b/recipes/iproute2/iproute2_2.6.34.bb
@@ -1,10 +1,16 @@
require iproute2.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
-SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}.tar.bz2"
+SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}.tar.bz2 \
+ file://configure-cross.patch \
+ "
SRC_URI[md5sum] = "5c5742bdac05a1688f266512e685b83c"
SRC_URI[sha256sum] = "f7feb3c34df4714cae0265f7629863af8b0a88550f4f38aba0ffc81a10c29bbb"
-S = "${WORKDIR}/iproute2-${PV}" \ No newline at end of file
+S = "${WORKDIR}/iproute2-${PV}"
+
+do_configure () {
+ ./configure ${STAGING_DIR_TARGET}
+}