aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/javasqlite/javasqlite-mkconst-native_20080130.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/javasqlite/javasqlite-mkconst-native_20080130.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/javasqlite/javasqlite-mkconst-native_20080130.bb')
-rw-r--r--recipes/javasqlite/javasqlite-mkconst-native_20080130.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes/javasqlite/javasqlite-mkconst-native_20080130.bb b/recipes/javasqlite/javasqlite-mkconst-native_20080130.bb
new file mode 100644
index 0000000000..e6f9a8e1ae
--- /dev/null
+++ b/recipes/javasqlite/javasqlite-mkconst-native_20080130.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "mkcons program needed for javasqlite build"
+HOMEPAGE = "http://www.ch-werner.de/javasqlite"
+LICENSE = "BSD"
+
+DEPENDS = "sqlite-native sqlite3-native"
+
+SRC_URI = "\
+ http://www.ch-werner.de/javasqlite/javasqlite-${PV}.tar.gz \
+ file://build-fix.patch;patch=1"
+
+S = "${WORKDIR}/javasqlite-${PV}"
+
+inherit autotools native
+
+# Program names are there to fool configure checks
+# because we actually do not need these.
+EXTRA_OECONF = " \
+ --with-sqlite-incdir=${STAGING_INCDIR} \
+ --with-sqlite-libdir=${STAGING_LIBDIR} \
+ --with-sqlite3-incdir=${STAGING_INCDIR} \
+ --with-sqlite3-libdir=${STAGING_LIBDIR} \
+ --with-jardir=${datadir_java} \
+ --with-native-libdir=${libdir_jni} \
+ --with-java='echo version 1.5' \
+ --with-javac=true \
+ --with-jar=true \
+ --with-javah=true \
+ --with-javadoc=true \
+ "
+
+do_configurepre() {
+ sed -i -e "s|wrong-libtool|${BUILD_SYS}-libtool|" Makefile.in
+}
+
+addtask configurepre after do_patch before do_configure
+
+
+do_compile() {
+ oe_runmake native/mkconst
+}
+
+do_install() {
+ :
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 0755 native/.libs/mkconst ${STAGING_BINDIR}/javasqlite-mkconst-${PV}
+}
+
+PACKAGES = ""
+