aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexec-tools
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/kexec-tools
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/kexec-tools')
-rw-r--r--recipes/kexec-tools/kexec-tools-dietlibc_2.0.1.bb2
-rw-r--r--recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb4
-rw-r--r--recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb4
-rw-r--r--recipes/kexec-tools/kexec-tools.inc4
-rw-r--r--recipes/kexec-tools/kexec-tools2.inc8
5 files changed, 11 insertions, 11 deletions
diff --git a/recipes/kexec-tools/kexec-tools-dietlibc_2.0.1.bb b/recipes/kexec-tools/kexec-tools-dietlibc_2.0.1.bb
index c428cd6c2b..ab9cb51d55 100644
--- a/recipes/kexec-tools/kexec-tools-dietlibc_2.0.1.bb
+++ b/recipes/kexec-tools/kexec-tools-dietlibc_2.0.1.bb
@@ -1,7 +1,7 @@
# the binaries are statical linked against dietlibc
require kexec-tools2.inc
-SRC_URI += "file://dietlibc.patch;apply=yes"
+SRC_URI += "file://dietlibc.patch"
inherit dietlibc
diff --git a/recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb b/recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb
index 17e4cf7871..65fb02165c 100644
--- a/recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb
+++ b/recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb
@@ -4,8 +4,8 @@ require kexec-tools.inc
PR = "r8"
DEPENDS = "klibc"
-SRC_URI += "file://kexec-static.patch;apply=yes \
- file://kexec-klibc.patch;apply=yes \
+SRC_URI += "file://kexec-static.patch \
+ file://kexec-klibc.patch \
"
S = "${WORKDIR}/kexec-tools-${PV}"
diff --git a/recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb b/recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb
index 440b342f2d..bbd1753af0 100644
--- a/recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb
+++ b/recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb
@@ -6,8 +6,8 @@ DEFAULT_PREFERENCE = "1"
PR = "r4"
DEPENDS = "klibc"
-SRC_URI += "file://kexec-tools-2-headers.patch;apply=yes \
- file://kexec-tools-2-klibc.patch;apply=yes \
+SRC_URI += "file://kexec-tools-2-headers.patch \
+ file://kexec-tools-2-klibc.patch \
"
S = "${WORKDIR}/kexec-tools-${PV}"
diff --git a/recipes/kexec-tools/kexec-tools.inc b/recipes/kexec-tools/kexec-tools.inc
index 434be716c2..0ff1c31cc0 100644
--- a/recipes/kexec-tools/kexec-tools.inc
+++ b/recipes/kexec-tools/kexec-tools.inc
@@ -9,5 +9,5 @@ inherit autotools
SRC_URI = "http://www.xmission.com/~ebiederm/files/kexec/kexec-tools-${PV}.tar.gz \
- file://kexec-tools-arm.patch;apply=yes \
- file://kexec-arm-atags.patch;apply=yes"
+ file://kexec-tools-arm.patch \
+ file://kexec-arm-atags.patch"
diff --git a/recipes/kexec-tools/kexec-tools2.inc b/recipes/kexec-tools/kexec-tools2.inc
index 1463b9ab3e..a007cc2565 100644
--- a/recipes/kexec-tools/kexec-tools2.inc
+++ b/recipes/kexec-tools/kexec-tools2.inc
@@ -9,8 +9,8 @@ inherit autotools
SRC_URI = "http://www.kernel.org/pub/linux/kernel/people/horms/kexec-tools/kexec-tools-${PV}.tar.gz \
- file://fix-arm-arch-detection.patch;apply=yes \
- file://no-getline-no-fscanf.patch;apply=yes \
- file://kexec-tools-2-arm-add-uImage.patch;apply=yes \
- file://kexec-tools-2-autoconf-post-2.63.patch;apply=yes \
+ file://fix-arm-arch-detection.patch \
+ file://no-getline-no-fscanf.patch \
+ file://kexec-tools-2-arm-add-uImage.patch \
+ file://kexec-tools-2-autoconf-post-2.63.patch \
"