aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexec-tools
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-03-31 00:25:52 +0200
committerAndrea Adami <andrea.adami@gmail.com>2010-03-31 00:28:43 +0200
commit9ac5e400b1031ff7c23e9e42521ae033b38c1cac (patch)
tree92b8a06ebd451b5ff124b034d5d9671bfa925f0d /recipes/kexec-tools
parentf95a95435ca79e7b9942b6e321d30e264c728791 (diff)
downloadopenembedded-9ac5e400b1031ff7c23e9e42521ae033b38c1cac.tar.gz
kexec-tools_2.01: fix configure.ac for autoconf > 2.63
* see debian bug #543081
Diffstat (limited to 'recipes/kexec-tools')
-rw-r--r--recipes/kexec-tools/files/kexec-tools-2-autoconf-post-2.63.patch44
-rw-r--r--recipes/kexec-tools/kexec-tools2.inc1
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/kexec-tools/files/kexec-tools-2-autoconf-post-2.63.patch b/recipes/kexec-tools/files/kexec-tools-2-autoconf-post-2.63.patch
new file mode 100644
index 0000000000..a06134a592
--- /dev/null
+++ b/recipes/kexec-tools/files/kexec-tools-2-autoconf-post-2.63.patch
@@ -0,0 +1,44 @@
+Index: kexec-tools-2.0.1/configure.ac
+===================================================================
+--- kexec-tools-2.0.1/configure.ac.old 2009-08-13 01:28:04.000000000 +0200
++++ kexec-tools-2.0.1/configure.ac 2010-03-31 00:04:41.000000000 +0200
+@@ -150,23 +150,23 @@
+ fi
+
+ dnl ---Sanity checks
+-if test "$CC" = "no"; then AC_MSG_ERROR([cc not found]) fi
+-if test "$CPP" = "no"; then AC_MSG_ERROR([cpp not found]) fi
+-if test "$LD" = "no"; then AC_MSG_ERROR([ld not found]) fi
+-if test "$AS" = "no"; then AC_MSG_ERROR([as not found]) fi
+-if test "$OBJCOPY" = "no"; then AC_MSG_ERROR([objcopy not found]) fi
+-if test "$AR" = "no"; then AC_MSG_ERROR([ar not found]) fi
++if test "$CC" = "no"; then AC_MSG_ERROR([cc not found]); fi
++if test "$CPP" = "no"; then AC_MSG_ERROR([cpp not found]); fi
++if test "$LD" = "no"; then AC_MSG_ERROR([ld not found]); fi
++if test "$AS" = "no"; then AC_MSG_ERROR([as not found]); fi
++if test "$OBJCOPY" = "no"; then AC_MSG_ERROR([objcopy not found]); fi
++if test "$AR" = "no"; then AC_MSG_ERROR([ar not found]); fi
+
+-if test "$MKDIR" = "no"; then AC_MSG_ERROR([ mkdir not found]) fi
+-if test "$RM" = "no"; then AC_MSG_ERROR([ rm not found]) fi
+-if test "$CP" = "no"; then AC_MSG_ERROR([ cp not found]) fi
+-if test "$LN" = "no"; then AC_MSG_ERROR([ ln not found]) fi
+-if test "$TAR" = "no"; then AC_MSG_ERROR([ tar not found]) fi
+-if test "$RPM" = "no"; then AC_MSG_ERROR([ rpm not found]) fi
+-if test "$SED" = "no"; then AC_MSG_ERROR([ sed not found]) fi
+-if test "$FIND" = "no"; then AC_MSG_ERROR([ find not found]) fi
+-if test "$XARGS" = "no"; then AC_MSG_ERROR([ xargs not found]) fi
+-if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]) fi
++if test "$MKDIR" = "no"; then AC_MSG_ERROR([ mkdir not found]); fi
++if test "$RM" = "no"; then AC_MSG_ERROR([ rm not found]); fi
++if test "$CP" = "no"; then AC_MSG_ERROR([ cp not found]); fi
++if test "$LN" = "no"; then AC_MSG_ERROR([ ln not found]); fi
++if test "$TAR" = "no"; then AC_MSG_ERROR([ tar not found]); fi
++if test "$RPM" = "no"; then AC_MSG_ERROR([ rpm not found]); fi
++if test "$SED" = "no"; then AC_MSG_ERROR([ sed not found]); fi
++if test "$FIND" = "no"; then AC_MSG_ERROR([ find not found]); fi
++if test "$XARGS" = "no"; then AC_MSG_ERROR([ xargs not found]); fi
++if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]); fi
+
+ dnl ---Output variables...
+ AC_SUBST([BUILD_CC])
diff --git a/recipes/kexec-tools/kexec-tools2.inc b/recipes/kexec-tools/kexec-tools2.inc
index a21afe4003..68dc5ba396 100644
--- a/recipes/kexec-tools/kexec-tools2.inc
+++ b/recipes/kexec-tools/kexec-tools2.inc
@@ -12,4 +12,5 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/people/horms/kexec-tools/kexec
file://fix-arm-arch-detection.patch;patch=1 \
file://no-getline-no-fscanf.patch;patch=1 \
file://kexec-tools-2-arm-add-uImage.patch;patch=1 \
+ file://kexec-tools-2-autoconf-post-2.63.patch;patch=1 \
"