aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexec-tools
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-12-26 17:15:44 +0100
committerAndrea Adami <andrea.adami@gmail.com>2009-12-26 17:15:44 +0100
commitb13f255cc0a748993f721385474171b7ba679633 (patch)
treeeff822f2e5708a424d7ce02c058f3223ea270cd8 /recipes/kexec-tools
parent9ef1480ac4d35ba5d354daf877b289072d7dd87b (diff)
downloadopenembedded-b13f255cc0a748993f721385474171b7ba679633.tar.gz
kexec-tools-klibc-static: don't use OE compiler flags. Use default
klcc and save 20kb size omitting ggdb3. Bump PR.
Diffstat (limited to 'recipes/kexec-tools')
-rw-r--r--recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb7
-rw-r--r--recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb7
2 files changed, 12 insertions, 2 deletions
diff --git a/recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb b/recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb
index 3ee699b1b3..579af3658e 100644
--- a/recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb
+++ b/recipes/kexec-tools/kexec-tools-klibc-static_1.101.bb
@@ -1,7 +1,7 @@
# the binaries are statical linked against klibc
require kexec-tools.inc
-PR = "r7"
+PR = "r8"
DEPENDS = "klibc"
SRC_URI += "file://kexec-static.patch;patch=1 \
@@ -11,6 +11,11 @@ S = "${WORKDIR}/kexec-tools-${PV}"
EXTRA_OECONF = " --without-zlib"
+# reset inherited OE flags to avoid e.g. ggdb3 and keep size small
+export CFLAGS=""
+export CPPFLAGS=""
+export LDFLAGS=""
+
export CC=${TARGET_PREFIX}klcc
PACKAGES =+ "kexec-klibc-static kdump-klibc-static"
diff --git a/recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb b/recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb
index 1c2327f82e..fbe8e0032e 100644
--- a/recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb
+++ b/recipes/kexec-tools/kexec-tools-klibc-static_2.0.1.bb
@@ -3,7 +3,7 @@ require kexec-tools2.inc
DEFAULT_PREFERENCE = "1"
-PR = "r3"
+PR = "r4"
DEPENDS = "klibc"
SRC_URI += "file://kexec-tools-2-headers.patch;patch=1 \
@@ -16,6 +16,11 @@ EXTRA_OECONF = " --without-zlib"
export CC=${TARGET_PREFIX}klcc
+# reset inherited OE flags to avoid e.g. ggdb3 and keep size small
+export CFLAGS=""
+export CPPFLAGS=""
+export LDFLAGS=""
+
PACKAGES =+ "kexec-klibc-static kdump-klibc-static"
FILES_kexec-klibc-static = "${sbindir}/kexec"