aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtheora/libtheora_0.9+1.0alpha7.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-25 22:11:44 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-30 02:00:13 +0100
commit70ed28415451e49b5759a44cf7a8c5b6443164fd (patch)
tree5bb617a96fa23e42a67c7c8102ffa3ef5de4419a /recipes/libtheora/libtheora_0.9+1.0alpha7.bb
parent454d36fb54dd392ad70bbfb1978ca2b337c689e1 (diff)
downloadopenembedded-70ed28415451e49b5759a44cf7a8c5b6443164fd.tar.gz
libtheora: update to version 1.1.1
* put recipes into its own dir * switch to INC_PR and newer oe autotools feature * remove dependency on libvorbis libogg is enough * add dependency for pkgconfig to find libogg * bump PR
Diffstat (limited to 'recipes/libtheora/libtheora_0.9+1.0alpha7.bb')
-rw-r--r--recipes/libtheora/libtheora_0.9+1.0alpha7.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/libtheora/libtheora_0.9+1.0alpha7.bb b/recipes/libtheora/libtheora_0.9+1.0alpha7.bb
new file mode 100644
index 0000000000..5a372b65a1
--- /dev/null
+++ b/recipes/libtheora/libtheora_0.9+1.0alpha7.bb
@@ -0,0 +1,19 @@
+
+DEPENDS = "libogg libvorbis libsdl-x11"
+
+SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-1.0alpha7.tar.gz"
+
+S = "${WORKDIR}/libtheora-1.0alpha7"
+
+inherit autotools pkgconfig lib_package
+
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+