aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtiff
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-17 15:37:53 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-18 08:16:40 -0700
commit30535972a51ef992c22876c9aada4357e53bd7a0 (patch)
treed903d52ff69dcc56539b632a4825fb5fd81d5e50 /recipes/libtiff
parentaf75d1bbac07cddde4a454f39e0421ec92e1f1ed (diff)
downloadopenembedded-30535972a51ef992c22876c9aada4357e53bd7a0.tar.gz
tiff: Fix RPATH QA issues
Based on the fix for 'acl' Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/libtiff')
-rw-r--r--recipes/libtiff/tiff_3.9.4.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/recipes/libtiff/tiff_3.9.4.bb b/recipes/libtiff/tiff_3.9.4.bb
index f54a19b405..b64b72e5ee 100644
--- a/recipes/libtiff/tiff_3.9.4.bb
+++ b/recipes/libtiff/tiff_3.9.4.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.remotesensing.org/libtiff/"
DEPENDS = "zlib jpeg lzo"
PV = "3.9.4+4.0.0beta6"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://download.osgeo.org/libtiff/tiff-4.0.0beta6.tar.gz \
file://tiff-lp589145.diff;striplevel=0 \
@@ -16,7 +16,13 @@ S = "${WORKDIR}/tiff-4.0.0beta6"
inherit autotools
-EXTRA_OECONF = "--without-x"
+EXTRA_OECONF = "--without-x --disable-rpath"
+
+do_configure_append() {
+ # Fix RPATH issues.
+ sed -i ${S}/config.status -e s,^\\\(hardcode_into_libs=\\\).*$,\\1\'no\',
+ ${S}/config.status
+}
PACKAGES =+ "tiffxx tiffxx-dbg tiffxx-dev tiff-utils tiff-utils-dbg"
FILES_tiffxx = "${libdir}/libtiffxx.so.*"