aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtool/libtool-cross_2.4.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-04 22:32:15 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-10 00:02:13 -0700
commitcc81e081f88ebcde16c6ecb0b468a8c49de33bea (patch)
treed19512be8cdb4150f69435e32b95be26479e0662 /recipes/libtool/libtool-cross_2.4.bb
parent60336c58a30aeb28cf798822786b187dc113291d (diff)
downloadopenembedded-cc81e081f88ebcde16c6ecb0b468a8c49de33bea.tar.gz
libtool-2.4: Add recipes for libtool 2.4
* Add fixes needed for sysroot working within libtool * Let nativesdk recipe not provide PACKAGES provided by libtool Otherwise when an image wants say libltdl-dev it picks up libtool-nativesdk instead of libtool recipe to provide it Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/libtool/libtool-cross_2.4.bb')
-rw-r--r--recipes/libtool/libtool-cross_2.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/libtool/libtool-cross_2.4.bb b/recipes/libtool/libtool-cross_2.4.bb
new file mode 100644
index 0000000000..e20c2c3074
--- /dev/null
+++ b/recipes/libtool/libtool-cross_2.4.bb
@@ -0,0 +1,34 @@
+require libtool_${PV}.bb
+
+PACKAGES = ""
+SRC_URI_append = " file://prefix.patch \
+ file://cross.patch \
+ "
+
+DEPENDS += "libtool-native"
+
+do_configure_prepend () {
+ # Remove any existing libtool m4 since old stale versions would break
+ # any upgrade
+ rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
+ rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
+}
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
+ install -d ${D}${datadir}/libtool/
+ install -d ${D}${datadir}/aclocal/
+ install -c ${S}/libltdl/config/config.guess ${D}${datadir}/libtool/
+ install -c ${S}/libltdl/config/config.sub ${D}${datadir}/libtool/
+ install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${D}${datadir}/libtool/
+ install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${D}${datadir}/aclocal/
+ install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${D}${datadir}/aclocal/
+}
+
+SYSROOT_PREPROCESS_FUNCS += "libtoolcross_sysroot_preprocess"
+
+libtoolcross_sysroot_preprocess () {
+ install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
+ install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
+}