aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-efika_2.6.21+git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-efika_2.6.21+git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-efika_2.6.21+git.bb')
-rw-r--r--recipes/linux/linux-efika_2.6.21+git.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes/linux/linux-efika_2.6.21+git.bb b/recipes/linux/linux-efika_2.6.21+git.bb
new file mode 100644
index 0000000000..20b5bf86b6
--- /dev/null
+++ b/recipes/linux/linux-efika_2.6.21+git.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "Linux Kernel for the EFIKA dev platform"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r0"
+PV = "2.6.21+git${SRCDATE}"
+
+DEFAULT_PREFERENCE = "-1"
+
+COMPATIBLE_MACHINE = "efika"
+
+SRC_URI = "file://defconfig"
+
+S = "${WORKDIR}/linux-2.6"
+
+inherit kernel
+
+export ARCH="powerpc"
+
+
+do_fetch () {
+ cd ${WORKDIR}
+ git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git
+ cd linux-2.6
+ git fetch git://git.secretlab.ca/git/linux-2.6.git 52xx-dev:sl-52xx
+ git checkout sl-52xx
+ # todo: fix to revision f20d894bd207f8bae9b7869fa039a83e7ab2c6d8 here. It works.
+ mkdir patches
+ cd patches
+ wget http://www.246tnt.com/mpc52xx/2.6.22/0006-powerpc-Set-efika-s-device_type-to-soc.patch
+ wget http://www.246tnt.com/mpc52xx/2.6.22/0007-serial-powerpc-Don-t-shutdown-TX-on-mpc5200-serial.patch
+ wget http://www.246tnt.com/mpc52xx/2.6.22/0008-powerpc-mpc52xx-suspend-to-deep-sleep.patch
+}
+
+do_patch() {
+ cd ${S}
+ patch -F40 -p1 -i patches/0006-powerpc-Set-efika-s-device_type-to-soc.patch
+ patch -F40 -p1 -i patches/0007-serial-powerpc-Don-t-shutdown-TX-on-mpc5200-serial.patch
+ patch -F40 -p1 -i patches/0008-powerpc-mpc52xx-suspend-to-deep-sleep.patch
+}
+
+do_configure() {
+ install -m 644 ${WORKDIR}/defconfig ${S}/.config
+ make ARCH=${ARCH} oldconfig
+}
+
+do_stage_append () {
+#need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
+
+ install -d ${STAGING_KERNEL_DIR}/arch/
+ cp -pPR arch/ppc ${STAGING_KERNEL_DIR}/arch/
+ cp -pPR arch/powerpc ${STAGING_KERNEL_DIR}/arch/
+
+ install -d ${STAGING_KERNEL_DIR}/include/asm
+ cp -pPR include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
+ cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
+}