aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.29.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-09-24 19:10:28 +0200
committerJeremy Lainé <jeremy.laine@m4x.org>2009-09-24 19:10:28 +0200
commitaaef70f186aa239669269a8a4237b6d3dc99b5f5 (patch)
treefec42fa50a6e0e82531f9ee92f309f7614e9ad6b /recipes/linux/linux_2.6.29.bb
parentb16b5316677842fbdfaa997062145555623886a4 (diff)
downloadopenembedded-aaef70f186aa239669269a8a4237b6d3dc99b5f5.tar.gz
linux-2.6.29: add devicetree image for boc01 v1 and v2
Diffstat (limited to 'recipes/linux/linux_2.6.29.bb')
-rw-r--r--recipes/linux/linux_2.6.29.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/recipes/linux/linux_2.6.29.bb b/recipes/linux/linux_2.6.29.bb
index 2e9e769820..ba50a9b3a2 100644
--- a/recipes/linux/linux_2.6.29.bb
+++ b/recipes/linux/linux_2.6.29.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r8"
+PR = "r9"
S = "${WORKDIR}/linux-2.6.29"
@@ -23,6 +23,7 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.29.tar.bz2 \
SRC_URI_append_boc01 = "\
file://boc01.dts \
+ file://boc01.dts.v1 \
file://004-081205-usb.patch;patch=1 \
file://005-090226-isl12024.patch;patch=1 \
file://007-090825-lm73.patch;patch=1 \
@@ -73,3 +74,16 @@ SRC_URI_append_stamp9g20evb = " \
CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),0x230000(root),-(config);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd4 rootfstype=jffs2"
+do_devicetree_image_append_boc01() {
+ dtc -I dts -O dtb ${KERNEL_DEVICETREE_FLAGS} -o devicetree.v1 ${KERNEL_DEVICETREE}.v1
+ install -m 0644 devicetree.v1 ${D}/boot/devicetree-${KERNEL_VERSION}.v1
+}
+
+pkg_postinst_kernel-devicetree_append_boc01 () {
+ cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/devicetree.v1 devicetree.v1 devicetree-${KERNEL_VERSION}.v1 ${KERNEL_PRIORITY} || true
+}
+
+pkg_postrm_kernel-devicetree_append_boc01 () {
+ cd /${KERNEL_IMAGEDEST}; update-alternatives --remove devicetree.v1 devicetree-${KERNEL_VERSION}.v1 || true
+}
+