aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb')
-rw-r--r--recipes/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb b/recipes/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
new file mode 100644
index 0000000000..b001763710
--- /dev/null
+++ b/recipes/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
@@ -0,0 +1,71 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for MNCI device"
+LICENSE = "GPL"
+DEPENDS = "modutils-cross virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX}"
+COMPATIBLE_MACHINE = "mnci"
+KV = "2.4.21"
+RMKV = "2"
+PXAV = "1"
+PR = "r5"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
+ http://ftp.linux.org.uk/pub/linux/arm/kernel/v2.4/patch-${KV}-rmk${RMKV}.bz2;patch=1 \
+ file://diff-${KV}-rmk${RMKV}-pxa${PXAV}.gz;patch=1 \
+ file://mnci-combined.patch;patch=1"
+
+S = "${WORKDIR}/linux-${KV}"
+
+inherit kernel
+
+KERNEL_CCSUFFIX = "-3.3.4"
+
+# Put the zImage into kernel-image
+ALLOW_EMPTY_kernel = "1"
+FILES_kernel = ""
+FILES_kernel-image += "/tmp/zImage"
+
+do_configure_prepend() {
+ install -m 0644 ${S}/arch/arm/def-configs/${MACHINE} ${S}/.config || die "No default configuration for ${MACHINE} available."
+}
+
+kernel_do_install() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
+ oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" modules_install
+ else
+ oenote "no modules to install"
+ fi
+ install -d ${D}/tmp
+ install -m 0644 ${KERNEL_OUTPUT} ${D}/tmp
+ install -d ${D}/boot
+ install -m 0644 .config ${D}/boot/config-${PV}
+ bzip2 -9 ${D}/boot/*
+ install -d ${D}${sysconfdir}/modutils
+}
+
+
+pkg_postinst_kernel-image () {
+test -f /tmp/zImage || exit 0
+cp /tmp/zImage /dev/mtdblock/1
+rm /tmp/zImage
+sync
+cat /dev/mtdblock/1 >/dev/null
+}
+
+pkg_postinst_kernel () {
+}
+
+pkg_postinst_modules () {
+if [ -n "$D" ]; then
+ ${HOST_PREFIX}depmod-${KERNEL_MAJOR_VERSION} -A -b $D -F $D/boot/System.map-${PV} ${KERNEL_VERSION}
+else
+ depmod -A
+fi
+}
+
+pkg_postrm_modules () {
+}
+
+pkg_postrm_kernel () {
+}
+