aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/midpath/midpath-cldc_0.2+0.3rc2.bb
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-12-22 13:51:25 +0200
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-12-23 17:53:02 +0100
commit5667943cd09eb025ac382535e41269d874a6d560 (patch)
treeb96e226aa2db378603965d0396b552ed902e5094 /recipes/midpath/midpath-cldc_0.2+0.3rc2.bb
parent2e02ec3cfae08fc62821a2034210f9bbb6f337d2 (diff)
downloadopenembedded-5667943cd09eb025ac382535e41269d874a6d560.tar.gz
midpath: Fix midpath-core and midpath-cldc, add patches.
midpath-core was slightly refactored, and now installs the configuration files needed which are picked up locally and can be overriden per-platform. A much more elegant solution, in my opinion. Two patches were added to midpath-core, one which changes the default UI colors to a more palatable gray pallete and one which disables the mouse cursor and enables key repeating for the SDL backend. midpath-cldc now builds files libmidpathfile and libmidpathnio (via --enable-cldc-vm) which are required, at least for a jamvm + midpath combo. No harm in installing them anyways. Configuration files moved around, and two more added, one default and one for the ben-nanonote. PR bumbed all around. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/midpath/midpath-cldc_0.2+0.3rc2.bb')
-rw-r--r--recipes/midpath/midpath-cldc_0.2+0.3rc2.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes/midpath/midpath-cldc_0.2+0.3rc2.bb b/recipes/midpath/midpath-cldc_0.2+0.3rc2.bb
index a2307aea57..d87e82b5e4 100644
--- a/recipes/midpath/midpath-cldc_0.2+0.3rc2.bb
+++ b/recipes/midpath/midpath-cldc_0.2+0.3rc2.bb
@@ -1,6 +1,6 @@
require midpath-common.inc
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz"
@@ -27,10 +27,14 @@ do_compile() {
--disable-opengl-api \
--disable-m3g-api \
--disable-demos \
+ --enable-cldc-vm \
--with-cldc-jar=dist/${JAR}
}
do_install() {
+ oe_libinstall -C dist -so libmidpathfile ${D}${libdir_jni}
+ oe_libinstall -C dist -so libmidpathnio ${D}${libdir_jni}
+
install -d ${D}${datadir}/midpath-cldc
install -m 0644 dist/${JAR} ${D}${datadir}/midpath-cldc
}
@@ -42,7 +46,8 @@ do_stage() {
PACKAGES = "${PN}"
-FILES_${PN} = "${datadir}/midpath-cldc/${JAR}"
+FILES_${PN} = "${datadir}/midpath-cldc/${JAR} ${libdir_jni}/*.so"
+FILES_${PN}-dbg = "${libdir_jni}/.debug"
SRC_URI[md5sum] = "d03cd88f51f82bbcfcfa5b65df0da5b0"
SRC_URI[sha256sum] = "e235ca7470e7cdfb90e3806fbcc1b2c450db286276136a2523c7ae26a804a100"