aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mokosuite2/mokophone_git.bb
diff options
context:
space:
mode:
authorDaniele Ricci <daniele.athome@gmail.com>2010-12-21 18:32:06 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-12-21 21:46:28 +0100
commit4bccf3c2dfdb2e0affae98e4be83836dfa554d5b (patch)
tree6bb8b44e1f32d6e8d62332ed62a0a993d71c29c0 /recipes/mokosuite2/mokophone_git.bb
parent6a6b70744cbfa008043d11cbc93af950f38adc77 (diff)
downloadopenembedded-4bccf3c2dfdb2e0affae98e4be83836dfa554d5b.tar.gz
mokosuite2: removed phone and panel from appbunch in favour of dedicated applications
* mokosuite2 SRCREV bump * mokohome SRCREV BUMP * libmokosuite2 SRCREV BUMP * mokopanel: new recipe * mokophone: new recipe Signed-off-by: Daniele Ricci <daniele.athome@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/mokosuite2/mokophone_git.bb')
-rw-r--r--recipes/mokosuite2/mokophone_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/mokosuite2/mokophone_git.bb b/recipes/mokosuite2/mokophone_git.bb
new file mode 100644
index 0000000000..b80a62631b
--- /dev/null
+++ b/recipes/mokosuite2/mokophone_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Desktop environment and phone stack GUI for SHR - phone application"
+HOMEPAGE = "http://gitorious.org/mokosuite2"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "libmokosuite libfreesmartphone-glib libphone-utils alsa-lib glib-2.0 dbus-glib elementary vala-native edje-native"
+SECTION = "misc/utils"
+
+PV = "1.0.99+gitr${SRCPV}"
+SRCREV = "ff9029c6ba64e90aa26cb70eedfc63071e095d78"
+
+SRC_URI = "git://gitorious.org/mokosuite2/mokophone.git;protocol=git"
+S = "${WORKDIR}/git"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc --enable-debug"
+FILES_${PN} += "${datadir}/mokosuite/phone"
+
+inherit autotools
+
+do_install_append() {
+ ln -s themes/gry.edj ${D}${datadir}/mokosuite/phone/theme.edj
+}