aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netsurf/libnsgif_0.0.2.bb
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-11-20 15:44:01 +0200
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-20 14:57:45 +0100
commite800b4433fe87669e960aa35361852217fb5721f (patch)
tree0ea562247bde39f9d290b693ba687b57579ee2e8 /recipes/netsurf/libnsgif_0.0.2.bb
parent18e9ef2b9b8f9c6353a44315f2efa410457b3ed2 (diff)
downloadopenembedded-e800b4433fe87669e960aa35361852217fb5721f.tar.gz
netsurf: Update netsurf, dependancies, add netsurf-fb recipe.
Updated netsurf-2.1 to netsurf-2.6 and updated fix_makefile.patch and debugxml_fix.patch for netsurf-2.6. Updated hubbub, libnsbmp, libnsgif, libparserutils from version 0.0.1 to version 0.0.2. Added two new recipes libcss and libwapcaplet which are needed by netsurf-2.6. Recipe libcss comes with patch no-werror.patch which removed the definition of -Werror from the makefile for building with gcc-4.5, as per the recommendation of the netsurf developers. Added netsurf-fb recipe, which builds netsurf with a framebuffer frontend, which is much lighter than the GTK frontend (and can run under a plain tty). The framebuffer frontend is set to use SDL because it's the most stable backend at the moment. Font rendering is handled by freetype and uses the DejaVu fonts. Added libnsfb, a framebuffer abstraction layer library needed by netsurf-fb along with a patch, no-werror.patch, which removes the definition of -Werror from the makefile for building with gcc-4.5. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/netsurf/libnsgif_0.0.2.bb')
-rw-r--r--recipes/netsurf/libnsgif_0.0.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/netsurf/libnsgif_0.0.2.bb b/recipes/netsurf/libnsgif_0.0.2.bb
new file mode 100644
index 0000000000..f9184b64ac
--- /dev/null
+++ b/recipes/netsurf/libnsgif_0.0.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Libnsgif is a decoding library for the GIF image file format"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsgif/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsgif-${PV}-src.tar.gz"
+PR = "r0"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libnsgif ${STAGING_LIBDIR}
+ install -m 0644 include/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_runmake install
+}
+
+SRC_URI[md5sum] = "08dd5fc3ea330784f6c1e55c58244749"
+SRC_URI[sha256sum] = "dcb68be6a49ecc376cfa283d2f1e7eae035c75f99c0934ac80951e1777059617"