aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/linux
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-14 09:50:17 -0700
committerTom Rini <tom_rini@mentor.com>2011-01-14 09:51:56 -0700
commit005d673172cccc2f5f9ce04b205411255e2d97b3 (patch)
treed290c765266814a9a681d3a582e3331451743264 /recipes/nonworking/linux
parentd5e10f2ec89104699402efbaa171d0294595a212 (diff)
downloadopenembedded-005d673172cccc2f5f9ce04b205411255e2d97b3.tar.gz
linux-jlime-jornada6xx 2.6.25: Move to nonworking
The git tree in question no longer seems to exist and wasn't trivial to find where it's moved to (if it was). Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/nonworking/linux')
-rw-r--r--recipes/nonworking/linux/linux-jlime-jornada6xx_2.6.25.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/nonworking/linux/linux-jlime-jornada6xx_2.6.25.bb b/recipes/nonworking/linux/linux-jlime-jornada6xx_2.6.25.bb
new file mode 100644
index 0000000000..502dc51eb1
--- /dev/null
+++ b/recipes/nonworking/linux/linux-jlime-jornada6xx_2.6.25.bb
@@ -0,0 +1,30 @@
+SECTION = "kernel"
+DESCRIPTION = "JLime Linux kernel for SuperH based Jornada 6xx"
+LICENSE = "GPLv2"
+PR = "r0"
+
+SRCREV = "${AUTOREV}"
+
+COMPATIBLE_HOST = "sh.*-linux"
+#COMPATIBLE_MACHINE = "jornada6xx"
+
+SRC_URI = "git://jlime.org/jlime-stable.git;protocol=git;branch=v2.6.25-stable"
+
+S = "${WORKDIR}/git"
+
+inherit kernel
+
+#Lets let 3.4.x handle the compilation of this one
+KERNEL_CCSUFFIX = "-3.4.4"
+
+ARCH = "sh"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${S}/config-hp6xx-2.6.25 ${S}/.config
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}
+}