aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/mISDN/misdn_cvs.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nonworking/mISDN/misdn_cvs.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/mISDN/misdn_cvs.bb')
-rw-r--r--recipes/nonworking/mISDN/misdn_cvs.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/nonworking/mISDN/misdn_cvs.bb b/recipes/nonworking/mISDN/misdn_cvs.bb
new file mode 100644
index 0000000000..865e41b2f9
--- /dev/null
+++ b/recipes/nonworking/mISDN/misdn_cvs.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "mISDN kernel packages"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+# hfcs_usb_endianchecks.diff does not apply cleanly anymore (cf. bug 240)
+# without it the package at least compiles. no guarantees about functionality.
+SRC_URI = "cvs://anonymous:readonly@cvs.isdn4linux.de/i4ldev;module=mISDN;method=pserver \
+# file://hfcs_usb_endianchecks.diff;patch=1 \
+ file://Makefile"
+
+S = "${WORKDIR}/mISDN/"
+
+inherit module
+
+do_compile_prepend() {
+ cp -f ${WORKDIR}/Makefile ${S}/
+ cp ${S}/drivers/isdn/hardware/mISDN/Makefile.v2.6 ${S}/drivers/isdn/hardware/mISDN/Makefile
+}
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/isdn/hardware/mISDN/
+ install -m 0644 ${S}/drivers/isdn/hardware/mISDN/*${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/isdn/hardware/mISDN
+}
+