aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/maemo
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-08-28 11:46:43 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-01 13:46:04 -0700
commit87350d079f980c84bba2bb4acdc3a598dc3de279 (patch)
tree12ef150c9c7b0cfa8d362495d9da5fd91986a754 /recipes/nonworking/maemo
parent4bbb807bf585dac8cd0d3f555c7344a09bbe5bea (diff)
downloadopenembedded-87350d079f980c84bba2bb4acdc3a598dc3de279.tar.gz
recipes: Move some recipes to nonworking for getting bitbake world.
* If a recipes has DEPENDS on another recipe which is nonworking then move the recipe in question to nonworking too. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/maemo')
-rw-r--r--recipes/nonworking/maemo/hildon-control-panel_0.9.1-1.2.bb21
-rw-r--r--recipes/nonworking/maemo/hildon-status-bar/source.patch11
-rw-r--r--recipes/nonworking/maemo/hildon-status-bar_0.8.11-1.bb15
-rw-r--r--recipes/nonworking/maemo/lessertunjo_0.0.10.bb25
-rw-r--r--recipes/nonworking/maemo/libosso-help_1.0.01.bb24
-rw-r--r--recipes/nonworking/maemo/osso-application-installer_1.0.03-1.bb22
6 files changed, 118 insertions, 0 deletions
diff --git a/recipes/nonworking/maemo/hildon-control-panel_0.9.1-1.2.bb b/recipes/nonworking/maemo/hildon-control-panel_0.9.1-1.2.bb
new file mode 100644
index 0000000000..3c56364363
--- /dev/null
+++ b/recipes/nonworking/maemo/hildon-control-panel_0.9.1-1.2.bb
@@ -0,0 +1,21 @@
+PR = "r2"
+LICENSE = "GPL"
+
+DEPENDS = "hildon-lgpl hildon-base-lib osso-af-settings libosso hildon-libs osso-af-settings libosso-help"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/h/${PN}/${PN}_${PV}.tar.gz \
+ file://config-path.patch;striplevel=0 \
+ file://noWerror.patch;striplevel=0"
+
+S = "${WORKDIR}/hildon-control-panel-0.9.1"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/dbus-1.0 ${datadir}/applications"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/hildon-cp-plugin
+ install -m 644 *.h ${STAGING_INCDIR}/hildon-cp-plugin
+}
+SRC_URI[md5sum] = "72c8b814ebeec8668cea575e08bb1548"
+SRC_URI[sha256sum] = "bbe77d297c7560d3fdad343ab49f23c9c0aa1574db77108d1b97845fb7bb26d5"
diff --git a/recipes/nonworking/maemo/hildon-status-bar/source.patch b/recipes/nonworking/maemo/hildon-status-bar/source.patch
new file mode 100644
index 0000000000..dd5e82b710
--- /dev/null
+++ b/recipes/nonworking/maemo/hildon-status-bar/source.patch
@@ -0,0 +1,11 @@
+--- status-bar-launch.sh.old 2005-06-14 17:12:10.000000000 +0200
++++ status-bar-launch.sh 2005-06-14 17:12:15.000000000 +0200
+@@ -21,7 +21,7 @@
+ # 02110-1301 USA
+ #
+
+-source af.conf
++. af.conf
+
+ if [ "$1" != "start" ] && [ "$1" != "stop" ] && [ "$1" != "restart" ]; then
+ echo "Usage: $0 {start|stop|restart}"
diff --git a/recipes/nonworking/maemo/hildon-status-bar_0.8.11-1.bb b/recipes/nonworking/maemo/hildon-status-bar_0.8.11-1.bb
new file mode 100644
index 0000000000..5d6238cd06
--- /dev/null
+++ b/recipes/nonworking/maemo/hildon-status-bar_0.8.11-1.bb
@@ -0,0 +1,15 @@
+PR = "r1"
+LICENSE = "GPL"
+
+DEPENDS = "hildon-lgpl libosso hildon-libs"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/h/${PN}/${PN}_${PV}.tar.gz \
+ file://source.patch;striplevel=0"
+
+S = "${WORKDIR}/hildon-status-bar-0.8.11"
+
+inherit autotools pkgconfig
+
+
+SRC_URI[md5sum] = "7948087bfe3b1bf8025a37fbb64bde44"
+SRC_URI[sha256sum] = "eca16f42de8e4a213acb3ba0978fa56fbdf2f38e5be5882163753068ab4a15cd"
diff --git a/recipes/nonworking/maemo/lessertunjo_0.0.10.bb b/recipes/nonworking/maemo/lessertunjo_0.0.10.bb
new file mode 100644
index 0000000000..691893d6a8
--- /dev/null
+++ b/recipes/nonworking/maemo/lessertunjo_0.0.10.bb
@@ -0,0 +1,25 @@
+LICENSE = "LGPL"
+
+DEPENDS = "gconf-osso hildon-libs dbus libosso"
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/l/lessertunjo/lessertunjo_${PV}-3.tar.gz"
+
+inherit pkgconfig
+
+S = "${WORKDIR}/lessertunjo"
+LDFLAGS += " -losso -L${STAGING_LIBDIR} -I${STAGING_INCDIR} -I${STAGING_LIBDIR}/dbus-1.0/include -I${STAGING_INCDIR}/dbus-1.0 -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_INCDIR}/gconf/2"
+
+
+do_install() {
+ install -d ${D}${libdir}
+ install -m 755 *so.0.0.10 ${D}${libdir}
+}
+
+do_stage() {
+ oe_libinstall -so libshadowapp libshadowappd ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}
+ install -m 644 *.h ${STAGING_INCDIR}
+
+}
+
+SRC_URI[md5sum] = "b6d7ca9e9740286f0ce918da9fb8438b"
+SRC_URI[sha256sum] = "0ee6a3caee4812827b8e167d4a07dbf859cb08a00a20f09568c3baae379d6ce8"
diff --git a/recipes/nonworking/maemo/libosso-help_1.0.01.bb b/recipes/nonworking/maemo/libosso-help_1.0.01.bb
new file mode 100644
index 0000000000..b80d45ad88
--- /dev/null
+++ b/recipes/nonworking/maemo/libosso-help_1.0.01.bb
@@ -0,0 +1,24 @@
+LICENSE = "LGPL"
+PR = "r0"
+
+DEPENDS = "libosso hildon-lgpl hildon-base-lib hildon-libs"
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/libo/${PN}/libosso-help_${PV}.tar.gz \
+ file://no-Werror.patch;striplevel=0 \
+ file://help-header-pp.patch;striplevel=0"
+
+inherit pkgconfig autotools
+
+S = "${WORKDIR}/libosso-help-sdk-${PV}"
+
+#FILES_${PN} += "${libdir}/dbus-1.0/services/ ${libdir}/outo/*.so ${libdir}/outo/*bin ${libdir}/outo/mimedummy.doc"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}
+ install -m 644 helplib/*.h ${STAGING_INCDIR}
+ install -m644 helplib/.libs/libossohelp.so ${STAGING_LIBDIR}
+ install -m644 helplib/.libs/libossohelp.so.0 ${STAGING_LIBDIR}
+ install -m644 helplib/.libs/libossohelp.so.0.0.0 ${STAGING_LIBDIR}
+}
+
+SRC_URI[md5sum] = "dbc3c68809e39bd6681aab8ad16ffe3c"
+SRC_URI[sha256sum] = "ef6f6fda31dfbf7b3186b6f1d0ffd12ee0675d9a057ad2994f81b5164213a693"
diff --git a/recipes/nonworking/maemo/osso-application-installer_1.0.03-1.bb b/recipes/nonworking/maemo/osso-application-installer_1.0.03-1.bb
new file mode 100644
index 0000000000..3d24f21905
--- /dev/null
+++ b/recipes/nonworking/maemo/osso-application-installer_1.0.03-1.bb
@@ -0,0 +1,22 @@
+PR = "r1"
+LICENSE = "GPL"
+
+DEPENDS = "hildon-lgpl hildon-base-lib libosso hildon-libs hildon-control-panel shared-mime-info"
+RDEPENDS_${PN} = "shared-mime-info"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/o/${PN}/${PN}_${PV}.tar.gz \
+ file://fix-buildsystem.patch"
+
+S = "${WORKDIR}/osso-application-installer-1.0.03"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/dbus-1.0 ${libdir}/hildon-control-panel/*.so ${datadir}/applications ${datadir}/mime"
+
+pkg_postinst () {
+ echo "Updating MIME database... this may take a while."
+ ${bindir}/update-mime-database ${datadir}/mime
+}
+
+SRC_URI[md5sum] = "05e47346d432bd4c78736b12f262d612"
+SRC_URI[sha256sum] = "f7129c56cd7e561c10457d101f37ebf3a8b02df83f42a30cb90b46eb0de5dede"