aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ntp
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-11 10:23:45 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-11 10:47:50 +0100
commita92ab702f023141f168a8a0f01072b0747f4afb0 (patch)
treef7fb8d58592e7450c29257924eb21e5e49b0f235 /recipes/ntp
parentf2a7e115ce1e36ec08955dc948844a0a721bcbe5 (diff)
downloadopenembedded-a92ab702f023141f168a8a0f01072b0747f4afb0.tar.gz
ntp: cleanups
* remove obsolete versions * move ntp-ssl forward * fix ifup script * fix crontab * moved files into files/ so it can be shared between ntp and ntp-ssl Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/ntp')
-rw-r--r--recipes/ntp/files/configure.patch362
-rw-r--r--recipes/ntp/files/gcc4.patch52
-rw-r--r--recipes/ntp/files/ipv6only-workaround.patch13
-rwxr-xr-xrecipes/ntp/files/ntpdate57
-rw-r--r--recipes/ntp/files/ntpdc.Makefile.am.maybe-layout.patch11
-rw-r--r--recipes/ntp/files/readline.patch44
-rw-r--r--recipes/ntp/files/tickadj.c.patch (renamed from recipes/ntp/ntp-4.2.4p7/tickadj.c.patch)0
-rwxr-xr-xrecipes/ntp/ntp-4.2.4p7/ntpdate49
-rwxr-xr-xrecipes/ntp/ntp-4.2.6p3/ntpdate49
-rw-r--r--recipes/ntp/ntp-4.2.6p3/tickadj.c.patch32
-rw-r--r--recipes/ntp/ntp-ssl_4.2.6p3.bb (renamed from recipes/ntp/ntp-ssl_4.1.2.bb)1
-rw-r--r--recipes/ntp/ntp_4.1.2.bb49
-rw-r--r--recipes/ntp/ntp_4.2.0.bb48
-rw-r--r--recipes/ntp/ntp_4.2.4p7.bb48
-rw-r--r--recipes/ntp/ntp_4.2.6p3.bb4
15 files changed, 39 insertions, 780 deletions
diff --git a/recipes/ntp/files/configure.patch b/recipes/ntp/files/configure.patch
deleted file mode 100644
index dc36b1bd12..0000000000
--- a/recipes/ntp/files/configure.patch
+++ /dev/null
@@ -1,362 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- ntp-4.1.2/./configure.in~configure
-+++ ntp-4.1.2/./configure.in
-@@ -1,12 +1,13 @@
- dnl -*-fundamental-*-
- dnl Process this file with autoconf to produce a configure script.
--AC_INIT(ntpd/ntp_refclock.c)
--AC_CANONICAL_SYSTEM
-+AC_INIT
-+AC_CONFIG_SRCDIR([ntpd/ntp_refclock.c])
-+AC_CANONICAL_TARGET([])
- AC_DEFINE_UNQUOTED(STR_SYSTEM, "$host", [canonical system (cpu-vendor-os) string])
- AM_CONFIG_HEADER(config.h)
- AC_ARG_PROGRAM
- AM_INIT_AUTOMAKE(ntp, 4.1.2)
--AC_PREREQ(2.53)
-+AC_PREREQ(2.57)
-
- ac_cv_var_atom_ok=no
- ac_cv_var_oncore_ok=no
-@@ -22,7 +23,7 @@
-
- dnl we need to check for cross compile tools for vxWorks here
- AC_PROG_CC
--AC_PROG_CC_STDC
-+
- AC_PROG_CPP
-
- case "$host" in
-@@ -294,19 +295,15 @@
- AC_CHECK_HEADER(nlist.h,
- [AC_DEFINE(NLIST_STRUCT, 1, [nlist stuff])
- AC_CACHE_CHECK([for n_un in struct nlist], ac_cv_struct_nlist_n_un,
--[AC_TRY_COMPILE([#include <nlist.h>],
--[struct nlist n; n.n_un.n_name = 0;],
--ac_cv_struct_nlist_n_un=yes, ac_cv_struct_nlist_n_un=no)])
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <nlist.h>]], [[struct nlist n; n.n_un.n_name = 0;]])],[ac_cv_struct_nlist_n_un=yes],[ac_cv_struct_nlist_n_un=no])])
- if test $ac_cv_struct_nlist_n_un = yes; then
- AC_DEFINE(NLIST_NAME_UNION, 1, [does struct nlist use a name union?])
- fi
- ])dnl
-
- AC_CACHE_CHECK(for basic volatile support, ac_cv_c_volatile,
--[AC_TRY_COMPILE([],[
--volatile int x;],
-- ac_cv_c_volatile=yes,
-- ac_cv_c_volatile=no)
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
-+volatile int x;]])],[ac_cv_c_volatile=yes],[ac_cv_c_volatile=no])
- ])
- case "$ac_cv_c_volatile" in
- yes)
-@@ -324,10 +321,10 @@
- ;;
- esac
- AC_CACHE_CHECK(if C compiler permits function prototypes, ac_cv_have_prototypes,
--[AC_TRY_COMPILE([
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- extern int foo (short);
--int foo(short i) { return i; }],[
--int i;], ac_cv_have_prototypes=yes, ac_cv_have_prototypes=no)
-+int foo(short i) { return i; }]], [[
-+int i;]])],[ac_cv_have_prototypes=yes],[ac_cv_have_prototypes=no])
- ])
- if test "$ac_cv_have_prototypes" = yes; then
- AC_DEFINE(HAVE_PROTOTYPES, 1, [Are function prototypes OK?])
-@@ -376,9 +373,8 @@
- esac
-
- dnl AC_CACHE_CHECK(ut_host in struct utmp, ac_cv_func_ut_host_in_utmp,
--dnl [AC_TRY_LINK([#include <sys/types.h>
--dnl #include <utmp.h>], [struct utmp ut; ut.ut_host;],
--dnl ac_cv_func_ut_host_in_utmp=yes, ac_cv_func_ut_host_in_utmp=no)])
-+dnl [AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
-+dnl #include <utmp.h>]], [[struct utmp ut; ut.ut_host;]])],[dnl ac_cv_func_ut_host_in_utmp=yes],[ac_cv_func_ut_host_in_utmp=no])])
- dnl if test $su_cv_func_ut_host_in_utmp = yes; then
- dnl AC_DEFINE(HAVE_UT_HOST)
- dnl fi
-@@ -401,12 +397,8 @@
- struct sigaction for sa_sigaction,
- ac_cv_struct_sigaction_has_sa_sigaction,
- [
-- AC_TRY_COMPILE(
-- [#include <signal.h>],
-- [struct sigaction act; act.sa_sigaction = 0;],
-- ac_cv_struct_sigaction_has_sa_sigaction=yes,
-- ac_cv_struct_sigaction_has_sa_sigaction=no
-- )
-+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <signal.h>]], [[struct sigaction act; act.sa_sigaction = 0;]])],[ac_cv_struct_sigaction_has_sa_sigaction=yes],[ac_cv_struct_sigaction_has_sa_sigaction=no
-+ ])
- ]
- )
- if test $ac_cv_struct_sigaction_has_sa_sigaction = yes; then
-@@ -414,7 +406,7 @@
- fi
-
- AC_CACHE_CHECK(for struct ppsclockev, ac_cv_struct_ppsclockev,
--[AC_TRY_COMPILE([
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <sys/types.h>
- #ifdef HAVE_SYS_TERMIOS_H
- # include <sys/termios.h>
-@@ -424,24 +416,20 @@
- #endif
- #ifdef HAVE_SYS_PPSCLOCK_H
- # include <sys/ppsclock.h>
--#endif],[
-+#endif]], [[
- extern struct ppsclockev *pce;
--return pce->serial;],
-- ac_cv_struct_ppsclockev=yes,
-- ac_cv_struct_ppsclockev=no)
-+return pce->serial;]])],[ac_cv_struct_ppsclockev=yes],[ac_cv_struct_ppsclockev=no])
- ])
- if test $ac_cv_struct_ppsclockev = yes; then
- AC_DEFINE(HAVE_STRUCT_PPSCLOCKEV, 1, [Does a system header define struct ppsclockev?])
- fi
-
- AC_CACHE_CHECK(struct sockaddr for sa_len, ac_cv_struct_sockaddr_has_sa_len,
--[AC_TRY_COMPILE([
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <sys/types.h>
--#include <sys/socket.h>],[
-+#include <sys/socket.h>]], [[
- extern struct sockaddr *ps;
--return ps->sa_len;],
-- ac_cv_struct_sockaddr_has_sa_len=yes,
-- ac_cv_struct_sockaddr_has_sa_len=no)
-+return ps->sa_len;]])],[ac_cv_struct_sockaddr_has_sa_len=yes],[ac_cv_struct_sockaddr_has_sa_len=no])
- ])
- if test $ac_cv_struct_sockaddr_has_sa_len = yes; then
- AC_DEFINE(HAVE_SA_LEN_IN_STRUCT_SOCKADDR, 1, [Should be obvious...])
-@@ -450,17 +438,15 @@
- case "$ac_cv_header_machine_soundcard_h$ac_cv_header_sys_soundcard_h" in
- *yes*)
- AC_CACHE_CHECK([for struct snd_size], ac_cv_struct_snd_size,
--[AC_TRY_COMPILE([
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #ifdef HAVE_MACHINE_SOUNDCARD_H
- # include <machine/soundcard.h>
- #endif
- #ifdef HAVE_SYS_SOUNDCARD_H
- # include <sys/soundcard.h>
--#endif],[
-+#endif]], [[
- extern struct snd_size *ss;
--return ss->rec_size;],
-- ac_cv_struct_snd_size=yes,
-- ac_cv_struct_snd_size=no)
-+return ss->rec_size;]])],[ac_cv_struct_snd_size=yes],[ac_cv_struct_snd_size=no])
- ])
- case "$ac_cv_struct_snd_size" in
- yes) AC_DEFINE(HAVE_STRUCT_SND_SIZE, 1,[Do we have struct snd_size?]) ;;
-@@ -469,31 +455,27 @@
- esac
-
- AC_CACHE_CHECK(struct clockinfo for hz, ac_cv_struct_clockinfo_has_hz,
--[AC_TRY_COMPILE([
--#include <sys/time.h>],[
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-+#include <sys/time.h>]], [[
- extern struct clockinfo *pc;
--return pc->hz;],
-- ac_cv_struct_clockinfo_has_hz=yes,
-- ac_cv_struct_clockinfo_has_hz=no)
-+return pc->hz;]])],[ac_cv_struct_clockinfo_has_hz=yes],[ac_cv_struct_clockinfo_has_hz=no])
- ])
- if test $ac_cv_struct_clockinfo_has_hz = yes; then
- AC_DEFINE(HAVE_HZ_IN_STRUCT_CLOCKINFO, 1, [Obvious...])
- fi
-
- AC_CACHE_CHECK(struct clockinfo for tickadj, ac_cv_struct_clockinfo_has_tickadj,
--[AC_TRY_COMPILE([
--#include <sys/time.h>],[
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-+#include <sys/time.h>]], [[
- extern struct clockinfo *pc;
--return pc->tickadj;],
-- ac_cv_struct_clockinfo_has_tickadj=yes,
-- ac_cv_struct_clockinfo_has_tickadj=no)
-+return pc->tickadj;]])],[ac_cv_struct_clockinfo_has_tickadj=yes],[ac_cv_struct_clockinfo_has_tickadj=no])
- ])
- if test $ac_cv_struct_clockinfo_has_tickadj = yes; then
- AC_DEFINE(HAVE_TICKADJ_IN_STRUCT_CLOCKINFO, 1, [Obvious...])
- fi
-
- AC_CACHE_CHECK([for struct timespec], ac_cv_struct_timespec,
--[AC_TRY_COMPILE([
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <sys/time.h>
- /* Under SunOS, timespec is in sys/timepps.h, which needs errno.h and FRAC */
- #ifdef HAVE_ERRNO_H
-@@ -502,19 +484,15 @@
- #ifdef HAVE_SYS_TIMEPPS_H
- # define FRAC 4294967296
- # include <sys/timepps.h>
--#endif],
--[struct timespec n;],
--ac_cv_struct_timespec=yes, ac_cv_struct_timespec=no)])
-+#endif]], [[struct timespec n;]])],[ac_cv_struct_timespec=yes],[ac_cv_struct_timespec=no])])
- if test $ac_cv_struct_timespec = yes; then
- AC_DEFINE(HAVE_STRUCT_TIMESPEC, 1, [Do we have struct timespec?])
- fi
-
- AC_CACHE_CHECK([for struct ntptimeval], ac_cv_struct_ntptimeval,
--[AC_TRY_COMPILE([
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <sys/time.h>
--#include <sys/timex.h>],
--[struct ntptimeval n;],
--ac_cv_struct_ntptimeval=yes, ac_cv_struct_ntptimeval=no)])
-+#include <sys/timex.h>]], [[struct ntptimeval n;]])],[ac_cv_struct_ntptimeval=yes],[ac_cv_struct_ntptimeval=no])])
- if test $ac_cv_struct_ntptimeval = yes; then
- AC_DEFINE(HAVE_STRUCT_NTPTIMEVAL, 1, [Do we have struct ntptimeval?])
- fi
-@@ -575,7 +553,7 @@
- # (prr) aix 4.1 doesn't have clock_settime, but in aix 4.3 it's a stub
- # (returning ENOSYS). I didn't check 4.2. If, in the future,
- # IBM pulls its thumbs out long enough to implement clock_settime,
-- # this conditional will need to change. Maybe use AC_TRY_RUN
-+ # this conditional will need to change. Maybe use AC_RUN_IFELSE([AC_LANG_SOURCE([[]])],[],[],[])
- # instead to try to set the time to itself and check errno.
- ;;
- *) AC_CHECK_FUNCS(clock_gettime clock_settime)
-@@ -587,10 +565,8 @@
- [AC_MSG_CHECKING(for isfinite with <math.h>)
- _libs=$LIBS
- LIBS="$LIBS -lm"
-- AC_TRY_LINK([#include <math.h>], [float f = 0.0; isfinite(f)],
-- [AC_MSG_RESULT(yes)
-- AC_DEFINE(HAVE_ISFINITE)],
-- AC_MSG_RESULT(no))
-+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <math.h>]], [[float f = 0.0; isfinite(f)]])],[AC_MSG_RESULT(yes)
-+ AC_DEFINE(HAVE_ISFINITE)],[AC_MSG_RESULT(no)])
- LIBS=$_libs])])
- AC_CHECK_FUNCS(getbootfile getclock getdtablesize getrusage)
- AC_CHECK_FUNC(gettimeofday, ,[
-@@ -691,26 +667,24 @@
- AC_CHECK_FUNCS(uname updwtmp updwtmpx vsprintf)
-
- AC_CACHE_CHECK(number of arguments to gettimeofday(), ac_cv_func_Xettimeofday_nargs,
--[AC_TRY_COMPILE([#include <sys/time.h>],[
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/time.h>]], [[
- gettimeofday((struct timeval*)0,(struct timezone*)0);
- settimeofday((struct timeval*)0,(struct timezone*)0);
--],
-- ac_cv_func_Xettimeofday_nargs=2, ac_cv_func_Xettimeofday_nargs=1)
-+]])],[ac_cv_func_Xettimeofday_nargs=2],[ac_cv_func_Xettimeofday_nargs=1])
- ])
- if test $ac_cv_func_Xettimeofday_nargs = 1; then
- AC_DEFINE(SYSV_TIMEOFDAY, 1, [Does Xettimeofday take 1 arg?])
- fi
-
- AC_CACHE_CHECK(number of arguments taken by setpgrp(), ac_cv_func_setpgrp_nargs,
--[AC_TRY_COMPILE([
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #ifdef HAVE_SYS_TYPES_H
- # include <sys/types.h>
- #endif
- #ifdef HAVE_UNISTD_H
- # include <unistd.h>
- #endif
--],[setpgrp(0,0);],
-- ac_cv_func_setpgrp_nargs=2, ac_cv_func_setpgrp_nargs=0)
-+]], [[setpgrp(0,0);]])],[ac_cv_func_setpgrp_nargs=2],[ac_cv_func_setpgrp_nargs=0])
- ])
- if test $ac_cv_func_setpgrp_nargs = 0; then
- AC_DEFINE(HAVE_SETPGRP_0, 1, [define if setpgrp takes 0 arguments])
-@@ -721,7 +695,7 @@
-
- AC_CACHE_CHECK(argument pointer type of qsort()'s compare function and base,
- ac_cv_func_qsort_argtype,
--[AC_TRY_COMPILE([
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include "l_stdlib.h"
-
- #ifdef HAVE_PROTOTYPES
-@@ -735,10 +709,9 @@
- int sortfunc(a, b)
- const void *a;
- const void *b; { return 0; }
--],[
-+]], [[
- qsort(base, 2, sizeof(char *), sortfunc);
--],
-- ac_cv_func_qsort_argtype=void, ac_cv_func_qsort_argtype=char)
-+]])],[ac_cv_func_qsort_argtype=void],[ac_cv_func_qsort_argtype=char])
- ])
- case "$ac_cv_func_qsort_argtype" in
- void)
-@@ -749,11 +722,9 @@
- CFLAGS=$save_CFLAGS
-
- AC_CACHE_CHECK(if we need to declare 'errno', ac_cv_decl_errno,
--[AC_TRY_COMPILE([#ifdef HAVE_ERRNO_H
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#ifdef HAVE_ERRNO_H
- #include <errno.h>
--#endif],
-- [errno = 0;],
-- ac_cv_decl_errno=no, ac_cv_decl_errno=yes)])
-+#endif]], [[errno = 0;]])],[ac_cv_decl_errno=no],[ac_cv_decl_errno=yes])])
- case "$ac_cv_decl_errno" in
- yes) AC_DEFINE(DECL_ERRNO, 1, [Declare errno?]) ;;
- esac
-@@ -767,7 +738,7 @@
- dnl without breaking any other platforms.
- dnl
- AC_CACHE_CHECK(if we may declare 'h_errno', ac_cv_decl_h_errno,
--[AC_TRY_COMPILE([#include <sys/types.h>
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
- #ifdef HAVE_NETINET_IN_H
- #include <netinet/in.h>
- #endif
-@@ -779,28 +750,24 @@
- #endif
- #ifdef HAVE_RESOLV_H
- #include <resolv.h>
--#endif],
-- [extern int h_errno;],
-- ac_cv_decl_h_errno=yes, ac_cv_decl_h_errno=no)])
-+#endif]], [[extern int h_errno;]])],[ac_cv_decl_h_errno=yes],[ac_cv_decl_h_errno=no])])
- case "$ac_cv_decl_h_errno" in
- yes) AC_DEFINE(DECL_H_ERRNO, 1, [Declare h_errno?]) ;;
- esac
-
- dnl See if char *sys_errlist[] is OK.
- AC_CACHE_CHECK([[if declaring 'char *sys_errlist[]' is ok]], ac_cv_decl_sys_errlist,
--[AC_TRY_COMPILE([#include <stdio.h>
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>
- #ifdef HAVE_ERRNO_H
- #include <errno.h>
--#endif],
-- [extern char *sys_errlist[];
--],
-- ac_cv_decl_sys_errlist=yes, ac_cv_decl_sys_errlist=no)])
-+#endif]], [[extern char *sys_errlist[];
-+]])],[ac_cv_decl_sys_errlist=yes],[ac_cv_decl_sys_errlist=no])])
- case "$ac_cv_decl_sys_errlist" in
- yes) AC_DEFINE(CHAR_SYS_ERRLIST, 1, [Declare char *sys_errlist array]) ;;
- esac
-
- AC_CACHE_CHECK(if declaring 'syscall()' is ok, ac_cv_decl_syscall,
--[AC_TRY_COMPILE([
-+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #ifdef HAVE_SYS_TYPES_H
- # include <sys/types.h>
- #endif
-@@ -812,9 +779,7 @@
- #else
- #define P(x) ()
- #endif
--],
-- [extern int syscall P((int, ...));],
-- ac_cv_decl_syscall=yes, ac_cv_decl_syscall=no)])
-+]], [[extern int syscall P((int, ...));]])],[ac_cv_decl_syscall=yes],[ac_cv_decl_syscall=no])])
- case "$ac_cv_decl_syscall" in
- yes) AC_DEFINE(DECL_SYSCALL, 1, [Declare syscall()?]) ;;
- esac
diff --git a/recipes/ntp/files/gcc4.patch b/recipes/ntp/files/gcc4.patch
deleted file mode 100644
index b7ae44a769..0000000000
--- a/recipes/ntp/files/gcc4.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Index: ntp-4.2.0/include/ntp_stdlib.h
-===================================================================
---- ntp-4.2.0.orig/include/ntp_stdlib.h 2003-07-17 11:27:16.000000000 +0100
-+++ ntp-4.2.0/include/ntp_stdlib.h 2005-11-26 18:39:14.000000000 +0000
-@@ -133,10 +133,6 @@
- extern u_char * cache_key; /* key pointer */
- extern u_int cache_keylen; /* key length */
-
--/* clocktypes.c */
--struct clktype;
--extern struct clktype clktypes[];
--
- /* getopt.c */
- extern char * ntp_optarg; /* global argument pointer */
- extern int ntp_optind; /* global argv index */
-Index: ntp-4.2.0/include/ntpd.h
-===================================================================
---- ntp-4.2.0.orig/include/ntpd.h 2003-09-13 04:08:04.000000000 +0100
-+++ ntp-4.2.0/include/ntpd.h 2005-11-26 18:38:45.000000000 +0000
-@@ -226,8 +226,6 @@
- #endif
-
- /* ntp_control.c */
--struct ctl_trap;
--extern struct ctl_trap ctl_trap[];
- extern int num_ctl_traps;
- extern keyid_t ctl_auth_keyid; /* keyid used for authenticating write requests */
-
-Index: ntp-4.2.0/include/ntp_refclock.h
-===================================================================
---- ntp-4.2.0.orig/include/ntp_refclock.h 2003-07-17 11:27:16.000000000 +0100
-+++ ntp-4.2.0/include/ntp_refclock.h 2005-11-26 18:40:23.000000000 +0000
-@@ -65,6 +65,7 @@
- const char *clocktype; /* long description */
- const char *abbrev; /* short description */
- };
-+extern struct clktype clktypes[];
-
- /*
- * Configuration flag values
-Index: ntp-4.2.0/include/ntp_control.h
-===================================================================
---- ntp-4.2.0.orig/include/ntp_control.h 2003-08-14 08:31:47.000000000 +0100
-+++ ntp-4.2.0/include/ntp_control.h 2005-11-26 18:41:22.000000000 +0000
-@@ -266,6 +267,7 @@
- u_char tr_flags; /* trap flags */
- u_char tr_version; /* version number of trapper */
- };
-+extern struct ctl_trap ctl_trap[];
-
- /*
- * Flag bits
diff --git a/recipes/ntp/files/ipv6only-workaround.patch b/recipes/ntp/files/ipv6only-workaround.patch
deleted file mode 100644
index 998d2bdad9..0000000000
--- a/recipes/ntp/files/ipv6only-workaround.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Patch taken from Debian: http://bugs.debian.org/249216
-------------------------------------------------------------------------
---- ntp-4.2.0/ntpdate/ntpdate.c~ipv6only-workaround
-+++ ntp-4.2.0/ntpdate/ntpdate.c
-@@ -1698,8 +1698,6 @@
- if (res->ai_family == AF_INET6)
- if (setsockopt(fd[nbsock], IPPROTO_IPV6, IPV6_V6ONLY, (void*) &optval, sizeof(optval)) < 0) {
- netsyslog(LOG_ERR, "setsockopt() IPV6_V6ONLY failed: %m");
-- exit(1);
-- /*NOTREACHED*/
- }
- #endif
-
diff --git a/recipes/ntp/files/ntpdate b/recipes/ntp/files/ntpdate
index b9963b772a..784b029ad5 100755
--- a/recipes/ntp/files/ntpdate
+++ b/recipes/ntp/files/ntpdate
@@ -2,7 +2,7 @@
PATH=/sbin:/bin:/usr/bin
-test -f /usr/bin/ntpdate || exit 0
+test -x /usr/bin/ntpdate || exit 0
if test -f /etc/default/ntpdate ; then
. /etc/default/ntpdate
@@ -12,23 +12,38 @@ fi
test -n "$NTPSERVERS" || exit 0
-case "$1" in
-start|force-reload)
- echo -n "Running ntpdate to synchronize clock"
- /usr/bin/ntpdate -u -b -s $NTPOPTIONS $NTPSERVERS
- echo "."
- ;;
-restart|reload)
- # Drop -b to slew clock rather than step it if called after system is up
- echo -n "Running ntpdate to synchronize clock"
- /usr/bin/ntpdate -u -s $NTPOPTIONS $NTPSERVERS
- echo "."
- ;;
-stop)
- ;;
-*)
- echo "Usage: /etc/init.d/ntpdate {start|stop|restart|reload|force-reload}"
- exit 1
-esac
-
-exit 0
+# This is a heuristic: The idea is that if a static interface is brought
+# up, that is a major event, and we can put in some extra effort to fix
+# the system time. Feel free to change this, especially if you regularly
+# bring up new network interfaces.
+if [ "$METHOD" = static ]; then
+ OPTS="-b"
+fi
+
+if [ "$METHOD" = loopback ]; then
+ exit 0
+fi
+
+(
+
+LOCKFILE=/var/lock/ntpdate
+
+# Avoid running more than one at a time
+if [ -x /usr/bin/lockfile-create ]; then
+ lockfile-create $LOCKFILE
+ lockfile-touch $LOCKFILE &
+ LOCKTOUCHPID="$!"
+fi
+
+if /usr/bin/ntpdate -s $OPTS $NTPSERVERS 2>/dev/null; then
+ if [ "$UPDATE_HWCLOCK" = "yes" ]; then
+ hwclock --systohc || :
+ fi
+fi
+
+if [ -x /usr/bin/lockfile-create ] ; then
+ kill $LOCKTOUCHPID
+ lockfile-remove $LOCKFILE
+fi
+
+) &
diff --git a/recipes/ntp/files/ntpdc.Makefile.am.maybe-layout.patch b/recipes/ntp/files/ntpdc.Makefile.am.maybe-layout.patch
deleted file mode 100644
index 826b5014d1..0000000000
--- a/recipes/ntp/files/ntpdc.Makefile.am.maybe-layout.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ntp-4.2.0/ntpdc/Makefile.am~nochecklayout Fri Jan 14 23:19:16 2005
-+++ ntp-4.2.0/ntpdc/Makefile.am Fri Jan 14 23:19:24 2005
-@@ -3,7 +3,7 @@
- bin_PROGRAMS= ntpdc
- EXTRA_PROGRAMS= ntpdc-layout
- EXTRA_DATA= check-layout
--BUILT_SOURCES= maybe-layout
-+BUILT_SOURCES= # maybe-layout
- INCLUDES= -I$(top_srcdir)/include
- # LDADD might need RESLIB and ADJLIB
- ntpdc_LDADD= version.o ../libntp/libntp.a @READLINE_LIBS@
diff --git a/recipes/ntp/files/readline.patch b/recipes/ntp/files/readline.patch
deleted file mode 100644
index 52d17db032..0000000000
--- a/recipes/ntp/files/readline.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- ntp-4.1.2/configure.in.old 2004-12-31 23:50:21.000000000 +0000
-+++ ntp-4.1.2/configure.in 2004-12-31 23:58:45.000000000 +0000
-@@ -211,16 +211,17 @@
- AC_CHECK_HEADERS(readline/history.h readline/readline.h)
- case "$ac_cv_header_readline_history_h$ac_cv_header_readline_readline_h" in
- *no*) ;;
-- *) AC_CHECK_LIB(readline, readline, ,
-+ *) AC_CHECK_LIB(readline, readline, READLINE_LIBS="-lreadline",
- AC_MSG_NOTICE([Trying again with -lcurses])
- unset ac_cv_lib_readline_readline
- AC_CHECK_LIB(readline, readline,
-- LIBS="-lreadline -lcurses $LIBS"
-+ READLINE_LIBS="-lreadline -lcurses"
- AC_DEFINE(HAVE_LIBREADLINE)
- AC_DEFINE(HAVE_LIBCURSES, , [Do we have the curses library?])
- , , -lcurses))
- ;;
- esac
-+AC_SUBST(READLINE_LIBS)
-
- dnl Digital UNIX V4.0 and Solaris 7 have POSIX.1c functions in -lrt
- dnl Solaris 2.6 only has -lposix4; in Solaris 7, this is a symlink to -lrt,
---- ntp-4.1.2/ntpdc/Makefile.am.old 2004-12-31 23:52:58.000000000 +0000
-+++ ntp-4.1.2/ntpdc/Makefile.am 2005-01-01 00:04:43.000000000 +0000
-@@ -4,6 +4,7 @@
- INCLUDES = -I$(top_srcdir)/include
- # LDADD might need RESLIB and ADJLIB
- LDADD = version.o ../libntp/libntp.a @LIBRSAREF@
-+LIBADD = @READLINE_LIBS@
- DISTCLEANFILES = .version version.c
- noinst_HEADERS = ntpdc.h
- #EXTRA_DIST = ntpdc.mak
---- ntp-4.1.2/ntpq/Makefile.am.old 2004-12-31 23:52:54.000000000 +0000
-+++ ntp-4.1.2/ntpq/Makefile.am 2005-01-01 00:04:54.000000000 +0000
-@@ -3,7 +3,8 @@
- bin_PROGRAMS = ntpq
- INCLUDES = -I$(top_srcdir)/include
- # LDADD might need RESLIB and ADJLIB
--LDADD = version.o ../libntp/libntp.a @LIBRSAREF@
-+LDADD = version.o ../libntp/libntp.a @LIBRSAREF@
-+LIBADD = @READLINE_LIBS@
- DISTCLEANFILES = .version version.c
- noinst_HEADERS = ntpq.h
- #EXTRA_DIST = ntpq.mak
diff --git a/recipes/ntp/ntp-4.2.4p7/tickadj.c.patch b/recipes/ntp/files/tickadj.c.patch
index 9ef9de9e1f..9ef9de9e1f 100644
--- a/recipes/ntp/ntp-4.2.4p7/tickadj.c.patch
+++ b/recipes/ntp/files/tickadj.c.patch
diff --git a/recipes/ntp/ntp-4.2.4p7/ntpdate b/recipes/ntp/ntp-4.2.4p7/ntpdate
deleted file mode 100755
index 784b029ad5..0000000000
--- a/recipes/ntp/ntp-4.2.4p7/ntpdate
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/sh
-
-PATH=/sbin:/bin:/usr/bin
-
-test -x /usr/bin/ntpdate || exit 0
-
-if test -f /etc/default/ntpdate ; then
-. /etc/default/ntpdate
-else
-NTPSERVERS="pool.ntp.org"
-fi
-
-test -n "$NTPSERVERS" || exit 0
-
-# This is a heuristic: The idea is that if a static interface is brought
-# up, that is a major event, and we can put in some extra effort to fix
-# the system time. Feel free to change this, especially if you regularly
-# bring up new network interfaces.
-if [ "$METHOD" = static ]; then
- OPTS="-b"
-fi
-
-if [ "$METHOD" = loopback ]; then
- exit 0
-fi
-
-(
-
-LOCKFILE=/var/lock/ntpdate
-
-# Avoid running more than one at a time
-if [ -x /usr/bin/lockfile-create ]; then
- lockfile-create $LOCKFILE
- lockfile-touch $LOCKFILE &
- LOCKTOUCHPID="$!"
-fi
-
-if /usr/bin/ntpdate -s $OPTS $NTPSERVERS 2>/dev/null; then
- if [ "$UPDATE_HWCLOCK" = "yes" ]; then
- hwclock --systohc || :
- fi
-fi
-
-if [ -x /usr/bin/lockfile-create ] ; then
- kill $LOCKTOUCHPID
- lockfile-remove $LOCKFILE
-fi
-
-) &
diff --git a/recipes/ntp/ntp-4.2.6p3/ntpdate b/recipes/ntp/ntp-4.2.6p3/ntpdate
deleted file mode 100755
index 784b029ad5..0000000000
--- a/recipes/ntp/ntp-4.2.6p3/ntpdate
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/sh
-
-PATH=/sbin:/bin:/usr/bin
-
-test -x /usr/bin/ntpdate || exit 0
-
-if test -f /etc/default/ntpdate ; then
-. /etc/default/ntpdate
-else
-NTPSERVERS="pool.ntp.org"
-fi
-
-test -n "$NTPSERVERS" || exit 0
-
-# This is a heuristic: The idea is that if a static interface is brought
-# up, that is a major event, and we can put in some extra effort to fix
-# the system time. Feel free to change this, especially if you regularly
-# bring up new network interfaces.
-if [ "$METHOD" = static ]; then
- OPTS="-b"
-fi
-
-if [ "$METHOD" = loopback ]; then
- exit 0
-fi
-
-(
-
-LOCKFILE=/var/lock/ntpdate
-
-# Avoid running more than one at a time
-if [ -x /usr/bin/lockfile-create ]; then
- lockfile-create $LOCKFILE
- lockfile-touch $LOCKFILE &
- LOCKTOUCHPID="$!"
-fi
-
-if /usr/bin/ntpdate -s $OPTS $NTPSERVERS 2>/dev/null; then
- if [ "$UPDATE_HWCLOCK" = "yes" ]; then
- hwclock --systohc || :
- fi
-fi
-
-if [ -x /usr/bin/lockfile-create ] ; then
- kill $LOCKTOUCHPID
- lockfile-remove $LOCKFILE
-fi
-
-) &
diff --git a/recipes/ntp/ntp-4.2.6p3/tickadj.c.patch b/recipes/ntp/ntp-4.2.6p3/tickadj.c.patch
deleted file mode 100644
index 9ef9de9e1f..0000000000
--- a/recipes/ntp/ntp-4.2.6p3/tickadj.c.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Index: ntp-4.2.2p3-r0/ntp-4.2.2p3/util/tickadj.c
-===================================================================
---- ntp-4.2.2p3/util/tickadj.c 2004-02-25 06:58:33.000000000 +0100
-+++ ntp-4.2.2p3/util/tickadj.c 2007-07-07 01:00:54.000000000 +0200
-@@ -21,7 +21,8 @@
- # include <unistd.h>
- #endif /* HAVE_UNISTD_H */
-
--#ifdef HAVE___ADJTIMEX /* Linux */
-+/* proper handling here has been moved to upstream ntp bugzilla */
-+#ifdef linux
-
- #include <sys/timex.h>
- struct timex txc;
-@@ -91,7 +92,7 @@
- }
-
- if (!errflg) {
-- if (__adjtimex(&txc) < 0)
-+ if (adjtimex(&txc) < 0)
- perror("adjtimex");
- else if (!quiet)
- printf("tick = %ld\ntick_adj = %d\n",
-@@ -146,7 +147,7 @@
- #endif
- }
-
-- if (__adjtimex(&txc) < 0)
-+ if (adjtimex(&txc) < 0)
- {
- perror("adjtimex");
- }
diff --git a/recipes/ntp/ntp-ssl_4.1.2.bb b/recipes/ntp/ntp-ssl_4.2.6p3.bb
index 7cd0921686..a158990792 100644
--- a/recipes/ntp/ntp-ssl_4.1.2.bb
+++ b/recipes/ntp/ntp-ssl_4.2.6p3.bb
@@ -1,6 +1,5 @@
require ntp_${PV}.bb
DEPENDS = "openssl"
-PR = "r2"
S = "${WORKDIR}/ntp-${PV}"
diff --git a/recipes/ntp/ntp_4.1.2.bb b/recipes/ntp/ntp_4.1.2.bb
deleted file mode 100644
index 24e9b05e45..0000000000
--- a/recipes/ntp/ntp_4.1.2.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-require ntp.inc
-
-PR = "r5"
-
-SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.1/ntp-${PV}.tar.gz \
- file://configure.patch \
- file://readline.patch \
- file://ntpdate \
- file://ntp"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d
- install -m 755 ${WORKDIR}/ntpdate ${D}${sysconfdir}/init.d
- install -m 755 ${WORKDIR}/ntp ${D}${sysconfdir}/init.d
- echo "server pool.ntp.org" >${D}${sysconfdir}/ntp.conf
-}
-
-pkg_postinst_ntpdate() {
-if test "x$D" != "x"; then
- exit 1
-else
- if ! grep -q ntpdate /etc/cron/crontabs/root >/dev/null 2>&1; then
- echo "adding crontab"
- test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
- echo "30 * * * * ${bindir}/ntpdate -s -u pool.ntp.org" >> /etc/cron/crontabs/root
- fi
-
- # Dunno why this is here, ask the "nylon" guys :)
- test -x /etc/init.d/busybox-cron && update-rc.d -s busybox-cron defaults
-
- update-rc.d -s ntpdate defaults 30
-fi
-}
-
-pkg_postrm_ntpdate() {
- update-rc.d -f ntpdate remove
-}
-
-pkg_postinst_ntp() {
- update-rc.d -s ntp defaults 31
-}
-
-pkg_postrm_ntp(){
- update-rc.d -f ntp remove
-}
-
-
-SRC_URI[md5sum] = "98e16c7aa4ecd4c004b51bff18962e95"
-SRC_URI[sha256sum] = "9f4a5271a285d390c9225e3ea28f70049ea377d30fc6de4659007cfff278671a"
diff --git a/recipes/ntp/ntp_4.2.0.bb b/recipes/ntp/ntp_4.2.0.bb
deleted file mode 100644
index 62342ca602..0000000000
--- a/recipes/ntp/ntp_4.2.0.bb
+++ /dev/null
@@ -1,48 +0,0 @@
-require ntp.inc
-
-PR = "r9"
-
-SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${P}.tar.gz \
- file://ntpdc.Makefile.am.maybe-layout.patch \
- file://ipv6only-workaround.patch \
- file://gcc4.patch \
- file://ntpd \
- file://ntp.conf \
- file://ntpdate"
-
-PROVIDES = "ntpdate-${PV} ntpdate-${PV}-${PR} ntpdate"
-
-#This is too painful - perl is only needed for ntp-wait and ntptrace, which are
-#perl scripts, and installing perl is an enormous overhead for a user who only
-#needs ntpq
-#RDEPENDS_ntp-bin = perl
-# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
-# with wonky clocks (e.g. OpenSlug)
-RDEPENDS_${PN} = "${PN}-tickadj"
-FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace"
-FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd"
-FILES_${PN}-tickadj = "${bindir}/tickadj"
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/init.d
- install -m 644 ${WORKDIR}/ntp.conf ${D}/${sysconfdir}
- install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/init.d
- install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d
-}
-
-pkg_postinst_ntpdate_nylon() {
-if test "x$D" != "x"; then
- exit 1
-else
- if ! grep -q ntpdate /etc/cron/crontabs/root; then
- echo "adding crontab"
- test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
- echo "30 * * * * /usr/bin/ntpdate -s -u pool.ntp.org" >> /etc/cron/crontabs/root
- fi
- update-rc.d -s busybox-cron defaults
- update-rc.d -s ntpdate defaults 30
-fi
-}
-
-SRC_URI[md5sum] = "0f8fabe87cf54f409b57c6283f0c0c3d"
-SRC_URI[sha256sum] = "da784d5c0363d4f708a25f3aad23ba9a3486aafd464444d2aa6a9f8d29213f25"
diff --git a/recipes/ntp/ntp_4.2.4p7.bb b/recipes/ntp/ntp_4.2.4p7.bb
deleted file mode 100644
index 803aa0c369..0000000000
--- a/recipes/ntp/ntp_4.2.4p7.bb
+++ /dev/null
@@ -1,48 +0,0 @@
-require ntp.inc
-
-PR = "r2"
-
-SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${P}.tar.gz \
- file://tickadj.c.patch \
- file://ntp-4.2.4_p6-nano.patch \
- file://ntpd \
- file://ntp.conf \
- file://ntpdate"
-
-SRC_URI[md5sum] = "8c19ff62ed4f7d64f8e2aa59cb11f364"
-SRC_URI[sha256sum] = "5681883ce5cd0666d73c1b907e284653964a25ad4c02a308ab11b54aca8f01c3"
-
-do_configure_prepend() {
- sed -i -e 's:dist_man_MANS= sntp.1::g' sntp/Makefile.am
-}
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/init.d
- install -m 644 ${WORKDIR}/ntp.conf ${D}/${sysconfdir}
- install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d
- install -d ${D}/${sysconfdir}/network/if-up.d
- install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/network/if-up.d
-}
-
-FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace"
-FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd"
-FILES_${PN}-tickadj = "${bindir}/tickadj"
-FILES_ntp-utils = "${bindir}/*"
-FILES_ntpdate = "${bindir}/ntpdate ${sysconfdir}/network/if-up.d/ntpdate"
-
-# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
-# with wonky clocks (e.g. OpenSlug)
-RDEPENDS_${PN} = "${PN}-tickadj"
-
-pkg_postinst_ntpdate() {
-if test "x$D" != "x"; then
- exit 1
-else
- if ! grep -q -s ntpdate /var/cron/tabs/root; then
- echo "adding crontab"
- test -d /var/cron/tabs || mkdir -p /var/cron/tabs
- echo "30 * * * * /usr/bin/ntpdate -s -u pool.ntp.org" >> /var/cron/tabs/root
- fi
-fi
-}
-
diff --git a/recipes/ntp/ntp_4.2.6p3.bb b/recipes/ntp/ntp_4.2.6p3.bb
index d17eb56254..1476c6fbb7 100644
--- a/recipes/ntp/ntp_4.2.6p3.bb
+++ b/recipes/ntp/ntp_4.2.6p3.bb
@@ -1,5 +1,7 @@
require ntp.inc
+PR = "r1"
+
SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${P}.tar.gz \
file://tickadj.c.patch \
file://ntp-4.2.4_p6-nano.patch \
@@ -37,7 +39,7 @@ else
if ! grep -q -s ntpdate /var/cron/tabs/root; then
echo "adding crontab"
test -d /var/cron/tabs || mkdir -p /var/cron/tabs
- echo "30 * * * * /usr/bin/ntpdate -s -u pool.ntp.org" >> /var/cron/tabs/root
+ echo "30 * * * * /usr/bin/ntpdate -b -s -u pool.ntp.org" >> /var/cron/tabs/root
fi
fi
}