aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opencvs/opencvs_cvs.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/opencvs/opencvs_cvs.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/opencvs/opencvs_cvs.bb')
-rw-r--r--recipes/opencvs/opencvs_cvs.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/opencvs/opencvs_cvs.bb b/recipes/opencvs/opencvs_cvs.bb
new file mode 100644
index 0000000000..d098821cc6
--- /dev/null
+++ b/recipes/opencvs/opencvs_cvs.bb
@@ -0,0 +1,20 @@
+# FIXME: Update to work with some other MD5 implementation.
+# It's silly to pull in OpenSSL just for that.
+DEPENDS = "openssl"
+DESCRIPTION = "BSD-licensed equivalent of the popular versioning system CVS."
+LICENSE = "BSD"
+PRIORITY = "optional"
+SECTION = "console/network"
+PV = "0.0+cvs${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "cvs://anoncvs@anoncvs.ca.openbsd.org/cvs;method=ext;module=src/usr.bin/cvs \
+ file://linux.patch;patch=1"
+S = "${WORKDIR}/cvs"
+
+inherit autotools
+
+do_clean_tree () {
+ rm -rf ${S}/cvs ${S}/cvsd
+}
+addtask clean_tree after do_patch before do_configure