aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg-utils
diff options
context:
space:
mode:
authorBernhard Guillon <Bernhard.Guillon@opensimpad.org>2011-05-20 05:50:42 +0000
committerBernhard Guillon <Bernhard.Guillon@opensimpad.org>2011-05-26 21:58:34 +0200
commit06addb6a8da6fef865880db3d03fbf334292e043 (patch)
tree1ca1b8596351600efccbcddff44c334e592d51cb /recipes/opkg-utils
parent275c62bfeb9b6416e8e6e449c23d19ea8550db9c (diff)
downloadopenembedded-06addb6a8da6fef865880db3d03fbf334292e043.tar.gz
opkg-utils: port arfile.py patch to opkg-utils, bump PR
We need this patch for opkg as well original commit b3da649ee25374f284d03ebce5843b6326559f73 original Author: Scott Anderson <o2e@saaworld.com> original commit message: ipkg-utils: Make arfile.py handle six digit UIDs Essentially, the problem is that arfile.py is splitting the ar header with white-space instead of fixed-width fields, so two fields would get treated as a single field. This makes things better than before as it now honors the fixed field widths. Signed-off-by: Bernhard Guillon <Bernhard.Guillon@opensimpad.org>
Diffstat (limited to 'recipes/opkg-utils')
-rw-r--r--recipes/opkg-utils/opkg-utils/arfile_header_split.patch17
-rw-r--r--recipes/opkg-utils/opkg-utils_svn.bb3
2 files changed, 19 insertions, 1 deletions
diff --git a/recipes/opkg-utils/opkg-utils/arfile_header_split.patch b/recipes/opkg-utils/opkg-utils/arfile_header_split.patch
new file mode 100644
index 0000000000..464036707f
--- /dev/null
+++ b/recipes/opkg-utils/opkg-utils/arfile_header_split.patch
@@ -0,0 +1,17 @@
+--- ipkg-utils/arfile.py.orig 2010-09-29 13:38:15.000000000 -0700
++++ ipkg-utils/arfile.py 2010-10-01 16:06:00.000000000 -0700
+@@ -74,7 +74,12 @@
+ if l == "\n":
+ l = self.f.readline()
+ if not l: break
+ l = l.replace('`', '')
+- descriptor = l.split()
++ # Field lengths from /usr/include/ar.h:
++ ar_field_lens = [ 16, 12, 6, 6, 8, 10, 2 ]
++ descriptor = []
++ for field_len in ar_field_lens:
++ descriptor.append(l[:field_len].strip())
++ l = l[field_len:]
+ # print descriptor
+ size = int(descriptor[5])
+ memberName = descriptor[0][:-1]
diff --git a/recipes/opkg-utils/opkg-utils_svn.bb b/recipes/opkg-utils/opkg-utils_svn.bb
index 6b8d3ea682..a8f2cb7eb0 100644
--- a/recipes/opkg-utils/opkg-utils_svn.bb
+++ b/recipes/opkg-utils/opkg-utils_svn.bb
@@ -6,10 +6,11 @@ RDEPENDS_${PN} = "python"
RDEPENDS_${PN}_virtclass-native = ""
SRCREV = "4747"
PV = "0.1.8+svnr${SRCPV}"
-PR = "r6"
+PR = "r7"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
file://index-ignore-filenotfound.patch \
+ file://arfile_header_split.patch \
file://mtime-int.patch"
S = "${WORKDIR}/opkg-utils"