aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg-utils
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-25 04:18:10 +0000
committerKhem Raj <raj.khem@gmail.com>2011-01-24 18:37:37 -0800
commit5876b9df76469d5c05a92b20d35bb6606a404af7 (patch)
treed7f57ab78bfa3e5ea6d3168044581e23ad6fc191 /recipes/opkg-utils
parent862f1dd152056fb138399a9defc1a40b45ae3ce5 (diff)
downloadopenembedded-5876b9df76469d5c05a92b20d35bb6606a404af7.tar.gz
opkg-utils_svn.bb: Sync with yocto
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/opkg-utils')
-rw-r--r--recipes/opkg-utils/opkg-utils/index-ignore-filenotfound.patch54
-rw-r--r--recipes/opkg-utils/opkg-utils_svn.bb24
2 files changed, 69 insertions, 9 deletions
diff --git a/recipes/opkg-utils/opkg-utils/index-ignore-filenotfound.patch b/recipes/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
new file mode 100644
index 0000000000..e4a548156f
--- /dev/null
+++ b/recipes/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
@@ -0,0 +1,54 @@
+If we're building an image and some package rebuilds while this is happening
+some package can be removed/added to the ipk deploy directory. The image will
+not depend on this package so we can safely ignore these cases rather than
+error out.
+
+RP - 26/8/09
+
+Index: opkg-utils/opkg-make-index
+===================================================================
+--- opkg-utils.orig/opkg-make-index 2009-08-26 17:21:26.000000000 +0100
++++ opkg-utils/opkg-make-index 2009-08-27 16:11:22.000000000 +0100
+@@ -96,6 +96,7 @@
+ files=glob(pkg_dir + '/*.ipk') + glob(pkg_dir + '/*.deb')
+ files.sort()
+ for filename in files:
++ try:
+ basename = os.path.basename(filename)
+ pkg = None
+ fnameStat = os.stat(filename)
+@@ -130,6 +131,12 @@
+ to_morgue(basename)
+ if opt_s:
+ print filename
++ except OSError:
++ sys.stderr.write("Package %s disappeared on us!\n" % (filename))
++ continue
++ except IOError:
++ sys.stderr.write("Package %s disappeared on us!\n" % (filename))
++ continue
+
+ pkgsStampsFile = open(stamplist_filename, "w")
+ for f in pkgsStamps.keys():
+@@ -148,6 +155,7 @@
+ names = packages.packages.keys()
+ names.sort()
+ for name in names:
++ try:
+ pkg = packages.packages[name]
+ if locales_dir and pkg.depends:
+ depends = string.split(pkg.depends, ',')
+@@ -165,6 +173,13 @@
+ if (verbose):
+ sys.stderr.write("Writing info for package %s\n" % (pkg.package,))
+ print pkg
++ except OSError:
++ sys.stderr.write("Package %s disappeared on us!\n" % (name))
++ continue
++ except IOError:
++ sys.stderr.write("Package %s disappeared on us!\n" % (name))
++ continue
++
+ if packages_filename:
+ sys.stdout.close()
+ sys.stdout = old_stdout
diff --git a/recipes/opkg-utils/opkg-utils_svn.bb b/recipes/opkg-utils/opkg-utils_svn.bb
index 46346908e5..951580a61b 100644
--- a/recipes/opkg-utils/opkg-utils_svn.bb
+++ b/recipes/opkg-utils/opkg-utils_svn.bb
@@ -1,18 +1,24 @@
DESCRIPTION = "OPKG Package Manager Utilities"
SECTION = "base"
+HOMEPAGE = "http://wiki.openmoko.org/wiki/Opkg"
PRIORITY = "optional"
-LICENSE = "GPL"
RDEPENDS_${PN} = "python"
-RDEPENDS_virtclass-native = ""
-SRCREV = "4595"
-PV = "0.0+svnr${SRCPV}"
+RDEPENDS_${PN}_virtclass-native = ""
+SRCREV = "4747"
+PV = "0.1.8+svnr${SRCPV}"
PR = "r5"
-BBCLASSEXTEND = "native"
-
-SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http"
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
+ file://index-ignore-filenotfound.patch"
-TARGET_CC_ARCH += "${LDFLAGS}"
S = "${WORKDIR}/opkg-utils"
-inherit autotools
+# Avoid circular dependencies from package_ipk.bbclass
+PACKAGES_virtclass-native = ""
+
+do_install() {
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install
+}
+
+BBCLASSEXTEND = "native"
+TARGET_CC_ARCH += "${LDFLAGS}"