aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg-utils
diff options
context:
space:
mode:
authorEnrico Scholz <enrico.scholz@sigma-chemnitz.de>2011-02-24 08:12:49 +0000
committerKhem Raj <raj.khem@gmail.com>2011-02-23 18:29:04 -0800
commitc81990aecae3bdf70a7c924699776b248ab7a006 (patch)
treea78c4d5aa25c2d6ecdb5ee32b022f14f97e71458 /recipes/opkg-utils
parent558eb989e115b4f5d27bc2bc931628124683ed5b (diff)
downloadopenembedded-c81990aecae3bdf70a7c924699776b248ab7a006.tar.gz
opkg-utils: convert mtime to int before comparing it
The st_mtime attribute (which is a float) is compared against a value from the timestamp database, which was stored as an integer there. When working on a filesystem with precise timestamps the comparision will fail nearly everytime hence. Although it might be possible to enhance the database to store the fractional part too, this will complicate things more than we would gain by this change. This patch was applied as 49e11b32906fc1becd9218bb3125f6fc8fa03fa4 to old ipkg-utils already. Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de> Acked-By: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/opkg-utils')
-rw-r--r--recipes/opkg-utils/opkg-utils/mtime-int.patch27
-rw-r--r--recipes/opkg-utils/opkg-utils_svn.bb5
2 files changed, 30 insertions, 2 deletions
diff --git a/recipes/opkg-utils/opkg-utils/mtime-int.patch b/recipes/opkg-utils/opkg-utils/mtime-int.patch
new file mode 100644
index 0000000000..efec3c09cc
--- /dev/null
+++ b/recipes/opkg-utils/opkg-utils/mtime-int.patch
@@ -0,0 +1,27 @@
+Convert mtime to int before comparing it
+
+The st_mtime attribute (which is a float) is compared against a value
+from the timestamp database, which was stored as an integer there.
+
+When working on a filesystem with precise timestamps the comparision
+will fail nearly everytime hence.
+
+Although it might be possible to enhance the database to store the
+fractional part too, this will complicate things more than we would
+gain by this change.
+
+Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de>
+
+Index: opkg-utils/opkg-make-index
+===================================================================
+--- opkg-utils.orig/opkg-make-index
++++ opkg-utils/opkg-make-index
+@@ -100,7 +100,7 @@ for filename in files:
+ pkg = None
+ fnameStat = os.stat(filename)
+ if old_pkg_hash.has_key(basename):
+- if pkgsStamps.has_key(basename) and fnameStat.st_mtime == pkgsStamps[basename]:
++ if pkgsStamps.has_key(basename) and int(fnameStat.st_mtime) == pkgsStamps[basename]:
+ if (verbose):
+ sys.stderr.write("Found %s in Packages\n" % (filename,))
+ pkg = old_pkg_hash[basename]
diff --git a/recipes/opkg-utils/opkg-utils_svn.bb b/recipes/opkg-utils/opkg-utils_svn.bb
index 951580a61b..6b8d3ea682 100644
--- a/recipes/opkg-utils/opkg-utils_svn.bb
+++ b/recipes/opkg-utils/opkg-utils_svn.bb
@@ -6,10 +6,11 @@ RDEPENDS_${PN} = "python"
RDEPENDS_${PN}_virtclass-native = ""
SRCREV = "4747"
PV = "0.1.8+svnr${SRCPV}"
-PR = "r5"
+PR = "r6"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
- file://index-ignore-filenotfound.patch"
+ file://index-ignore-filenotfound.patch \
+ file://mtime-int.patch"
S = "${WORKDIR}/opkg-utils"