aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg/opkg_svn.bb
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-06-29 18:54:00 +0000
committerKhem Raj <raj.khem@gmail.com>2010-08-03 13:02:24 -0700
commit11d08db8106e173599cf5efec58d2710c66bba51 (patch)
tree8319aa1b07152198f386fb8707d2b137734caf12 /recipes/opkg/opkg_svn.bb
parent060285f9fdb9bc0065f119a41edb15e0182c069c (diff)
downloadopenembedded-11d08db8106e173599cf5efec58d2710c66bba51.tar.gz
opkg recipe overhaul - removal of opkg-nogpg and opkg-nogpg-nocurl.
None of the distros in OE appear to want/need gpg or curl support in opkg; so have opkg.inc remove them by default. This diff makes things more consistent across all distros/tasks/images. The slugos recipe is kept intact and further divided from the more modern recipes. The opkg-native recipe is the sane-srcrev version even when building slugos, which should allow for changes to opkg related bbclasses without breaking the slugos build. Build tested for qemumipsel/minimal-image and nslu2/slugos-image. minimal-image builds 10% quicker in my setup and is 1mb smaller. Signed-off-by: Graham Gower <graham.gower@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/opkg/opkg_svn.bb')
-rw-r--r--recipes/opkg/opkg_svn.bb6
1 files changed, 0 insertions, 6 deletions
diff --git a/recipes/opkg/opkg_svn.bb b/recipes/opkg/opkg_svn.bb
index 5138458498..b193d7c55c 100644
--- a/recipes/opkg/opkg_svn.bb
+++ b/recipes/opkg/opkg_svn.bb
@@ -8,14 +8,8 @@ PACKAGES =+ "libopkg-dev libopkg"
FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
FILES_libopkg = "${libdir}/*.so.*"
-# not happens automatically for opkg-nogpg:
FILES_${PN} += "${datadir}/opkg/intercept"
-# Define a variable to allow distros to run configure earlier.
-# (for example, to enable loading of ethernet kernel modules before networking starts)
-OPKG_INIT_POSITION = "98"
-OPKG_INIT_POSITION_slugos = "41"
-
pkg_postinst_${PN} () {
update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
}