aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-27 10:23:53 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-01 10:51:02 -0700
commitc15142c5e3c5556e7a9d534e8b0a5aa175b79a3a (patch)
treea6f9e32a95f471722672ddab870291faf8373852 /recipes/perl/perl-native_5.8.8.bb
parent2e1e7af403777b5281957c9089b032e9a92ab0fd (diff)
downloadopenembedded-c15142c5e3c5556e7a9d534e8b0a5aa175b79a3a.tar.gz
perl: Drop 5.8.8, bump PR in all perl recipes
Also remove DEFAULT_PREFERENCE = -1 from 5.10.1 Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/perl/perl-native_5.8.8.bb')
-rw-r--r--recipes/perl/perl-native_5.8.8.bb114
1 files changed, 0 insertions, 114 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
deleted file mode 100644
index a7f85a30e6..0000000000
--- a/recipes/perl/perl-native_5.8.8.bb
+++ /dev/null
@@ -1,114 +0,0 @@
-DESCRIPTION = "Perl is a popular scripting language."
-HOMEPAGE = "http://www.perl.org/"
-SECTION = "libs"
-LICENSE = "Artistic|GPLv1+"
-DEPENDS = "virtual/db-native gdbm-native"
-PR = "r22"
-NATIVE_INSTALL_WORKS = "1"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
-
-SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/5.0/perl-${PV}.tar.gz \
- file://CPAN-Config.pm \
- file://perl-5.8.8-gcc-4.2.patch \
- file://Configure-multilib.patch \
- file://perl-configpm-switch.patch \
- file://native-nopacklist.patch \
- file://native-no-gdbminc.patch \
- file://native-perlinc.patch \
- file://makedepend-dash.patch \
- file://asm-pageh-fix.patch"
-
-S = "${WORKDIR}/perl-${PV}"
-
-inherit native
-
-do_configure () {
- ./Configure \
- -Dcc="${CC}" \
- -Dcflags="${CFLAGS}" \
- -Dldflags="${LDFLAGS}" \
- -Dcf_by="Open Embedded" \
- -Dprefix=${prefix} \
- -Dvendorprefix=${prefix} \
- -Dvendorprefix=${prefix} \
- -Dsiteprefix=${prefix} \
- \
- -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
- -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
- -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
- -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
- -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
- -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
- \
- -Duseshrplib \
- -Dusethreads \
- -Duseithreads \
- -Duselargefiles \
- -Dnoextensions=ODBM_File \
- -Ud_dosuid \
- -Ui_db \
- -Ui_ndbm \
- -Ui_gdbm \
- -Di_shadow \
- -Di_syslog \
- -Duseperlio \
- -Dman3ext=3pm \
- -Uafs \
- -Ud_csh \
- -Uusesfio \
- -Uusenm -des
- sed "s!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
- s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!;
- s!^installbin=.*!installbin=\'${STAGING_BINDIR}\'!;
- s!^installsitebin=.*!installsitebin=\'${STAGING_BINDIR}\'!" < config.sh > config.sh.new
- mv config.sh.new config.sh
-}
-
-do_install() {
- oe_runmake DESTDIR="${D}" install.perl
-
- # We need a hostperl link for building perl
- ln -sf perl${PV} ${D}${bindir}/hostperl
- # Store native config in non-versioned directory
- install -d ${D}${libdir}/perl/${PV}/CORE \
- ${D}${datadir}/perl/${PV}/ExtUtils
- install config.sh ${D}${libdir}/perl
- # Fix Errno.pm for target builds
- sed -i -r "s,^\tdie\ (\"Errno\ architecture.+)$,\twarn\ \1," ${D}${libdir}/perl/${PV}/Errno.pm
- # target configuration
- install lib/Config.pm ${D}${libdir}/perl/${PV}/
- install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/
- # perl shared library headers
- for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
- uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \
- perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \
- hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \
- cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \
- reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \
- nostdio.h perlapi.h perlvars.h reentr.inc thrdvar.h util.h \
- dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \
- thread.h warnings.h; do
- install $i ${D}${libdir}/perl/${PV}/CORE
- done
- # Make sure CPAN is configured
- sed -e "s,@SYSROOTBASE@,${base_prefix}," ${WORKDIR}/CPAN-Config.pm > \
- ${D}${libdir}/perl/${PV}/CPAN/Config.pm
-
- # Make sure we use /usr/bin/env perl
- for PERLSCRIPT in `grep -rIl ${bindir}/perl ${D}${bindir}`; do
- sed -i -e 's|^#!${bindir}/perl|#!/usr/bin/env perl|' $PERLSCRIPT
- done
-}
-
-do_install_append_nylon() {
- # get rid of definitions not supported by the gcc version we use for nylon...
- for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do
- perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
- done
-}
-
-PARALLEL_MAKE = ""
-
-SRC_URI[md5sum] = "b8c118d4360846829beb30b02a6b91a7"
-SRC_URI[sha256sum] = "e15d499321e003d12ed183601e37ee7ba5f64b278d1de30149ce01bd4a3f234d"