aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf@emagii.com>2012-01-31 10:55:23 +0100
committerUlf Samuelsson <ulf@emagii.com>2012-02-09 21:08:23 +0100
commit19f9a4e7806b44ee4bb72e6391cd0cca69c525de (patch)
tree168698930a286ca4d582b07ecbe1549caaa52f90 /recipes/perl
parent974979816495c7465e91ebc19d13b73f209948dd (diff)
downloadopenembedded-19f9a4e7806b44ee4bb72e6391cd0cca69c525de.tar.gz
perl_5.10.1.bb: Add search for libraries
Ubuntu 11.04 i686 has moved around the libraries. perl-native will not build due to this. Backported from 5.14.2 Signed-off-by: Ulf Samuelsson <ulf@emagii.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/files/0001-Find-pthread-libraries.patch31
-rw-r--r--recipes/perl/perl-native_5.10.1.bb3
-rw-r--r--recipes/perl/perl_5.10.1.bb4
3 files changed, 36 insertions, 2 deletions
diff --git a/recipes/perl/files/0001-Find-pthread-libraries.patch b/recipes/perl/files/0001-Find-pthread-libraries.patch
new file mode 100644
index 0000000000..f651dbd3d3
--- /dev/null
+++ b/recipes/perl/files/0001-Find-pthread-libraries.patch
@@ -0,0 +1,31 @@
+From 69f418972f17b7f03cdc335ad14af486d06d94b2 Mon Sep 17 00:00:00 2001
+From: Ulf Samuelsson <ulf@emagii.com>
+Date: Tue, 31 Jan 2012 09:59:31 +0100
+Subject: [PATCH] Find pthread libraries
+
+Signed-off-by: Ulf Samuelsson <ulf@emagii.com>
+---
+ hints/linux.sh | 10 ++++++++++
+ 1 files changed, 10 insertions(+), 0 deletions(-)
+
+diff --git a/hints/linux.sh b/hints/linux.sh
+index d208129..04a99da 100644
+--- a/hints/linux.sh
++++ b/hints/linux.sh
+@@ -441,3 +441,13 @@ case "$libdb_needs_pthread" in
+ libswanted="$libswanted pthread"
+ ;;
+ esac
++
++# plibpth to bypass this check.
++case "$plibpth" in
++ '') plibpth=`gcc -print-search-dirs | grep libraries | cut -f2- -d= | tr ':' $trnl | grep -v 'gcc' | sed -e 's:/$::'`
++ set X $plibpth # Collapse all entries on one line
++ shift
++ plibpth="$*"
++ ;;
++esac
++
+--
+1.7.4.1
+
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index 80d6937f8e..f37c6cbef8 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Perl is a popular scripting language."
HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
-PR = "r12"
+PR = "r13"
NATIVE_INSTALL_WORKS = "1"
INHIBIT_DEFAULT_DEPS = "1"
PATCHTOOL = "patch"
@@ -21,6 +21,7 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
file://native-perlinc.patch \
file://perl-fix-cross-library-check.patch \
file://ubuntu-11.04-multiarch.patch \
+ file://0001-Find-pthread-libraries.patch \
"
SRC_URI[perl-5.10.1.md5sum] = "b9b2fdb957f50ada62d73f43ee75d044"
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 6c0dcb16da..68eaaf1b62 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -75,7 +75,9 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
file://config.sh-32-be \
file://config.sh-64 \
file://config.sh-64-le \
- file://config.sh-64-be"
+ file://config.sh-64-be \
+ file://0001-Find-pthread-libraries.patch \
+ "
SRC_URI[perl-5.10.1.md5sum] = "b9b2fdb957f50ada62d73f43ee75d044"
SRC_URI[perl-5.10.1.sha256sum] = "cb7f26ea4b2b28d6644354d87a269d01cac1b635287dae64e88eeafa24b44f35"