aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-05-16 13:06:33 -0700
committerTom Rini <tom_rini@mentor.com>2011-05-16 13:07:38 -0700
commit1e255fbd296e95ff178d66c4a1fe4875a988d7e1 (patch)
treee8e118fe53aec725550602b54c56f3bfd26543a0 /recipes/perl
parentc9f48ba69fa0c3c1457ca590c98588c956ab376a (diff)
downloadopenembedded-1e255fbd296e95ff178d66c4a1fe4875a988d7e1.tar.gz
perl-native: create_wrapper on perl${PV} too
perl${PV} becomes hostperl when building for the target so we need a wrapper on that too. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl-native_5.10.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index 5aa0c7b123..5472c13d61 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Perl is a popular scripting language."
HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
-PR = "r10"
+PR = "r11"
NATIVE_INSTALL_WORKS = "1"
INHIBIT_DEFAULT_DEPS = "1"
PATCHTOOL = "patch"
@@ -105,6 +105,7 @@ do_install() {
done
create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
+ create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
}
do_install_append_nylon() {