aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorScott Ellis <scott@jumpnowtek.com>2011-04-18 04:22:46 -0400
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2011-05-16 22:27:48 +0200
commit86fde1fe0281cc8c9d2bf1012d8eff5e24a69e55 (patch)
tree9a15fbe75d6932840b6af3117bfe0e131b580a4c /recipes/perl
parent0b65da01d4e53164529cdaac8a09fb1a7d33b979 (diff)
downloadopenembedded-86fde1fe0281cc8c9d2bf1012d8eff5e24a69e55.tar.gz
perl-native multilib patch for ubuntu 11.04
Original patch from Scott Ellis Modified by US replacing `uname -m` by '*' to support non x86_64 targets (based on recommendations on the mailing list) Signed-off-by: Scott Ellis <scott@jumpnowtek.com> Signed-off-by: Ulf Samuelsson <ulf.samuelsson@atmel.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/files/ubuntu-11.04-multiarch.patch12
-rw-r--r--recipes/perl/perl-native_5.10.1.bb3
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes/perl/files/ubuntu-11.04-multiarch.patch b/recipes/perl/files/ubuntu-11.04-multiarch.patch
new file mode 100644
index 0000000000..4f51eb3a4e
--- /dev/null
+++ b/recipes/perl/files/ubuntu-11.04-multiarch.patch
@@ -0,0 +1,12 @@
+diff --git perl-5.10.1/Configure-orig perl-5.10.1/Configure
+index 5508fd2..8ee7dae 100755
+--- perl-5.10.1/Configure-orig
++++ perl-5.10.1/Configure
+@@ -1311,6 +1311,7 @@ glibpth="/lib /usr/lib /lib64 /usr/lib64 $xlibpth"
+ glibpth="$glibpth /usr/ccs/lib /usr/ucblib /usr/local/lib"
+ test -f /usr/shlib/libc.so && glibpth="/usr/shlib $glibpth"
+ test -f /shlib/libc.so && glibpth="/shlib $glibpth"
++test -f /usr/lib/*-linux-gnu/libc.so && glibpth="/usr/lib/*-linux-gnu $glibpth"
+ test -d /usr/lib64 && glibpth="$glibpth /lib64 /usr/lib64 /usr/local/lib64"
+
+ : Private path used by Configure to find libraries. Its value
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index 5472c13d61..fdbe055350 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -20,6 +20,7 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
file://native-nopacklist.patch \
file://native-perlinc.patch \
file://perl-fix-cross-library-check.patch \
+ file://ubuntu-11.04-multiarch.patch \
"
SRC_URI[perl-5.10.1.md5sum] = "b9b2fdb957f50ada62d73f43ee75d044"
@@ -29,6 +30,8 @@ S = "${WORKDIR}/perl-${PV}"
inherit native
+export LD="${CC}"
+
do_configure () {
./Configure \
-Dcc="${CC}" \