aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-11 14:11:12 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-11 14:11:12 +0000
commitb043fd916d4e8ab4a823b0ebd4eb5ab336ff2baf (patch)
treed5a17c1b511361ebc574607e71e4eee5200edd37 /recipes/perl
parent24f65d8096e185714b50b1e0bef084ea8cc8392d (diff)
downloadopenembedded-b043fd916d4e8ab4a823b0ebd4eb5ab336ff2baf.tar.gz
recipes: Fix recipes using do_stage_append or do_stage_prepend directly against base.bbclass
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/libhtml-mason-perl_1.35.bb4
-rw-r--r--recipes/perl/liblog-dispatch-perl_2.13.bb4
-rw-r--r--recipes/perl/libmodule-build-perl_0.2805.bb4
3 files changed, 12 insertions, 0 deletions
diff --git a/recipes/perl/libhtml-mason-perl_1.35.bb b/recipes/perl/libhtml-mason-perl_1.35.bb
index 71e96005e8..dfc6f3cc87 100644
--- a/recipes/perl/libhtml-mason-perl_1.35.bb
+++ b/recipes/perl/libhtml-mason-perl_1.35.bb
@@ -16,6 +16,10 @@ SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/HTML-Mason-${PV}.
S = "${WORKDIR}/HTML-Mason-${PV}"
+do_stage() {
+ :
+}
+
inherit cpan_build
do_install_append () {
diff --git a/recipes/perl/liblog-dispatch-perl_2.13.bb b/recipes/perl/liblog-dispatch-perl_2.13.bb
index ee4a2198c1..643deda664 100644
--- a/recipes/perl/liblog-dispatch-perl_2.13.bb
+++ b/recipes/perl/liblog-dispatch-perl_2.13.bb
@@ -7,4 +7,8 @@ SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Log-Dispatch-${PV
S = "${WORKDIR}/Log-Dispatch-${PV}"
+do_stage() {
+ :
+}
+
inherit cpan_build
diff --git a/recipes/perl/libmodule-build-perl_0.2805.bb b/recipes/perl/libmodule-build-perl_0.2805.bb
index 8a7ce9fa04..b7819fdebc 100644
--- a/recipes/perl/libmodule-build-perl_0.2805.bb
+++ b/recipes/perl/libmodule-build-perl_0.2805.bb
@@ -12,4 +12,8 @@ PR = "r5"
S = "${WORKDIR}/Module-Build-${PV}"
+do_stage() {
+ :
+}
+
inherit cpan_build