aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/povray/povray_3.6.1+3.7.0-beta25b.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/povray/povray_3.6.1+3.7.0-beta25b.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/povray/povray_3.6.1+3.7.0-beta25b.bb')
-rw-r--r--recipes/povray/povray_3.6.1+3.7.0-beta25b.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/povray/povray_3.6.1+3.7.0-beta25b.bb b/recipes/povray/povray_3.6.1+3.7.0-beta25b.bb
new file mode 100644
index 0000000000..5ca797cef6
--- /dev/null
+++ b/recipes/povray/povray_3.6.1+3.7.0-beta25b.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "The Persistence of Vision Raytracer is a high-quality, totally free tool for creating stunning three-dimensional graphics. "
+HOMEPAGE = "http://www.povray.org"
+SECTION = "console/graphics"
+LICENSE = "povray"
+DEPENDS = "virtual/libx11 boost zlib jpeg libpng tiff"
+
+PR = "r1"
+
+#We apply a patch that subverts the checks for jpeg, zlib, png and tiff because we know OE has the required versions, but it is still a hack.
+SRC_URI = "http://www.povray.org/redirect/www.povray.org/beta/source/povray-src-3.7.0.beta.25b.tar.bz2 \
+ file://configure-cross-hack.patch;patch=1 \
+ file://gcc43.diff;patch=1 \
+ "
+
+S = "${WORKDIR}/povray-3.7.0.beta.25b"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --with-boost-thread=boost_thread-mt \
+ --x-includes=${STAGING_INCDIR} \
+ --disable-vsnprintf-check \
+ COMPILED_BY=${MAINTAINER} "
+
+FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -O3 -ftree-vectorize -ffast-math -fno-math-errno "
+
+PACKAGES += "${PN}-scenes ${PN}-ini ${PN}-icons ${PN}-scripts ${PN}-includes"
+
+PACKAGE_ARCH_${PN}-doc = "all"
+
+PACKAGE_ARCH_${PN}-scenes = "all"
+FILES_${PN}-scenes = "${datadir}/povray-3.7/scenes"
+
+PACKAGE_ARCH_${PN}-ini = "all"
+FILES_${PN}-ini = "${datadir}/povray-3.7/ini"
+
+PACKAGE_ARCH_${PN}-icons = "all"
+FILES_${PN}-icons = "${datadir}/povray-3.7/icons"
+
+PACKAGE_ARCH_${PN}-scripts = "all"
+FILES_${PN}-scripts = "${datadir}/povray-3.7/scripts"
+
+PACKAGE_ARCH_${PN}-includes = "all"
+FILES_${PN}-includes = "${datadir}/povray-3.7/include"
+