aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pyzeroconf_0.12.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-pyzeroconf_0.12.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-pyzeroconf_0.12.bb')
-rw-r--r--recipes/python/python-pyzeroconf_0.12.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/python/python-pyzeroconf_0.12.bb b/recipes/python/python-pyzeroconf_0.12.bb
new file mode 100644
index 0000000000..4a8a9b018e
--- /dev/null
+++ b/recipes/python/python-pyzeroconf_0.12.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "A pure Python implementation of Zeroconf"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pyzeroconf/pyzeroconf-${PV}.tgz"
+S = "${WORKDIR}/pyzeroconf-${PV}"
+
+inherit distutils-base
+
+do_install() {
+ install -d ${D}${libdir}
+ install -d ${D}${libdir}/${PYTHON_DIR}
+ install -d ${D}${libdir}/${PYTHON_DIR}/site-packages
+
+ install -m 0644 Zeroconf.py ${D}${libdir}/${PYTHON_DIR}/site-packages/
+}