aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-soappy_0.11.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-soappy_0.11.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-soappy_0.11.6.bb')
-rw-r--r--recipes/python/python-soappy_0.11.6.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/python/python-soappy_0.11.6.bb b/recipes/python/python-soappy_0.11.6.bb
new file mode 100644
index 0000000000..fc7c49912c
--- /dev/null
+++ b/recipes/python/python-soappy_0.11.6.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Python SOAP Bindings"
+SECTION = "devel/python"
+HOMEPAGE = "http://pywebsvcs.sourceforge.net/"
+PRIORITY = "optional"
+LICENSE = "BSD"
+RDEPENDS = "python-xml python-fpconst"
+SRCNAME = "SOAPpy"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pywebsvcs/${SRCNAME}-${PV}.tar.gz \
+ file://fix-future.patch;patch=1 \
+ file://fpconst.py"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/fpconst.py ${S}/SOAPpy/fpconst.py
+}