aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qextserialport
diff options
context:
space:
mode:
authorMarc Reilly <marc@cpdesign.com.au>2010-12-22 10:50:54 +0000
committerKhem Raj <raj.khem@gmail.com>2010-12-25 18:27:11 -0800
commit8493126b6ec7027e8e4029c86f40f210213abe55 (patch)
tree9decf7d3f1dc4c4adb316300191205bfe6671017 /recipes/qextserialport
parentf118388495185c9469b69e68a6f9b7a2ebef17ef (diff)
downloadopenembedded-8493126b6ec7027e8e4029c86f40f210213abe55.tar.gz
qextserialport: Add qextserialport recipe.
Signed-off-by: Marc Reilly <marc@cpdesign.com.au> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/qextserialport')
-rw-r--r--recipes/qextserialport/qextserialport-e_hg.bb4
-rw-r--r--recipes/qextserialport/qextserialport.inc18
-rw-r--r--recipes/qextserialport/qextserialport_hg.bb4
3 files changed, 26 insertions, 0 deletions
diff --git a/recipes/qextserialport/qextserialport-e_hg.bb b/recipes/qextserialport/qextserialport-e_hg.bb
new file mode 100644
index 0000000000..f106ebd2a8
--- /dev/null
+++ b/recipes/qextserialport/qextserialport-e_hg.bb
@@ -0,0 +1,4 @@
+inherit qt4e
+
+require qextserialport.inc
+
diff --git a/recipes/qextserialport/qextserialport.inc b/recipes/qextserialport/qextserialport.inc
new file mode 100644
index 0000000000..db82de3bf5
--- /dev/null
+++ b/recipes/qextserialport/qextserialport.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Serial Port Library for Qt"
+SECTION = "libs"
+PRIORITY = "optional"
+
+PV = "0.0+${PR}+hg${SRCREV}"
+PR = "r0"
+
+SRCREV = "default"
+SRC_URI = "hg://qextserialport.googlecode.com/hg;rev=${SRCREV};module=qextserialport;proto=https"
+
+S = "${WORKDIR}/qextserialport"
+
+do_install() {
+ install -d ${D}${libdir} \
+ ${D}${includedir}
+ oe_libinstall -so -C src/build libqextserialport ${D}${libdir}
+ cp -pPR src/*.h ${D}${includedir}
+}
diff --git a/recipes/qextserialport/qextserialport_hg.bb b/recipes/qextserialport/qextserialport_hg.bb
new file mode 100644
index 0000000000..3464131a09
--- /dev/null
+++ b/recipes/qextserialport/qextserialport_hg.bb
@@ -0,0 +1,4 @@
+inherit qt4x11
+
+require qextserialport.inc
+