aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/recode
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/recode
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/recode')
-rw-r--r--recipes/recode/recode-3.6/recode-bitfield-width.patch13
-rw-r--r--recipes/recode/recode-native_3.6.bb5
-rw-r--r--recipes/recode/recode_3.6.bb26
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes/recode/recode-3.6/recode-bitfield-width.patch b/recipes/recode/recode-3.6/recode-bitfield-width.patch
new file mode 100644
index 0000000000..2c32886f2e
--- /dev/null
+++ b/recipes/recode/recode-3.6/recode-bitfield-width.patch
@@ -0,0 +1,13 @@
+Index: recode-3.6/src/recodext.h
+===================================================================
+--- recode-3.6.orig/src/recodext.h 2008-09-12 19:26:53.000000000 -0700
++++ recode-3.6/src/recodext.h 2008-09-12 19:27:15.000000000 -0700
+@@ -218,7 +218,7 @@
+ enum recode_symbol_type type : 3;
+
+ /* Non zero if this one should be ignored. */
+- bool ignore : 2;
++ bool ignore : 1;
+ };
+
+ struct recode_surface_list
diff --git a/recipes/recode/recode-native_3.6.bb b/recipes/recode/recode-native_3.6.bb
new file mode 100644
index 0000000000..af51f2c663
--- /dev/null
+++ b/recipes/recode/recode-native_3.6.bb
@@ -0,0 +1,5 @@
+require recode_${PV}.bb
+
+inherit native
+
+S = "${WORKDIR}/recode-${PV}/"
diff --git a/recipes/recode/recode_3.6.bb b/recipes/recode/recode_3.6.bb
new file mode 100644
index 0000000000..6fd60ae399
--- /dev/null
+++ b/recipes/recode/recode_3.6.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Charset converting utility"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+PR = "r1"
+SRC_URI = "${GNU_MIRROR}/recode/recode-${PV}.tar.gz"
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/recode-${PV}', '${FILE_DIRNAME}' ], d)}"
+
+SRC_URI += "file://recode-bitfield-width.patch;patch=1 \
+ "
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+ echo "#undef malloc" >>config.h
+ echo "#undef realloc" >>config.h
+}
+
+do_stage() {
+ install -m 0644 src/recode.h ${STAGING_INCDIR}/
+ install -m 0644 src/recodext.h ${STAGING_INCDIR}/
+ oe_libinstall -a -C src librecode ${STAGING_LIBDIR}/
+}
+