aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/smpeg
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-04-13 16:02:29 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-04-13 16:10:07 +0200
commitba5581f2258fccaf87245f5672c20d3cc43d1849 (patch)
tree0868ba08ced725324fe5db8659212f13fe9d85e7 /recipes/smpeg
parent3a31a6f3818a9ba0558d12da973abd00aaf973f7 (diff)
downloadopenembedded-ba5581f2258fccaf87245f5672c20d3cc43d1849.tar.gz
smpeg svn: fix compilation
Without that fix we have: [...] -L/usr/lib [...] libsmpeg-0.4.so.0 -o .libs/libsmpeg-0.4.so.0.1.4 /usr/lib/libm.so: file not recognized: File format not recognized In config.log we had: SDL_CFLAGS='-I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT' SDL_CONFIG='/usr/bin/sdl-config' SDL_LIBS='-L/usr/lib -lSDL' The solution was to pass the correct SDL_CONFIG to configure Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Diffstat (limited to 'recipes/smpeg')
-rw-r--r--recipes/smpeg/smpeg_svn.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/smpeg/smpeg_svn.bb b/recipes/smpeg/smpeg_svn.bb
index 8213877f92..e5443437b6 100644
--- a/recipes/smpeg/smpeg_svn.bb
+++ b/recipes/smpeg/smpeg_svn.bb
@@ -7,7 +7,7 @@ PROVIDES = "smpeg"
PV = "0.4.5+svnr${SRCPV}"
PE = "2"
SRCREV = "387"
-PR = "r1"
+PR = "r2"
SRC_URI = "svn://svn.icculus.org/smpeg/;module=trunk \
file://add-disable-rpath.patch"
@@ -17,7 +17,8 @@ S = "${WORKDIR}/trunk"
inherit autotools binconfig
EXTRA_OECONF = "--disable-gtktest --disable-opengl-player --without-x \
- --without-gtk --disable-gtk-player --disable-rpath"
+ --without-gtk --disable-gtk-player --disable-rpath \
+ SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config"
do_configure_prepend () {
touch NEWS AUTHORS ChangeLog