aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/supertux/supertux.inc
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-11-12 18:40:33 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-11-12 19:00:56 +0100
commit9a97090b98ee4177b806c305168473562580d0c7 (patch)
treedfc000d9e2daa180aea7f2422b997d65191c90af /recipes/supertux/supertux.inc
parent07105d2c3dae369cc3475a74a1d67fb2d1fdef04 (diff)
downloadopenembedded-9a97090b98ee4177b806c305168473562580d0c7.tar.gz
supertux/supertux-qvga : migrate to inc file, and fix supertux-qvga configure
supertux_0.1.3 and supertux-qvga_0.1.3 were doing that: supertux_0.1.3: PR = "r6" supertux-qvga_0.1.3: require supertux_${PV}.bb And supertux-qvga didn't redefine PR So I had to convert move supertux_0.1.3 to supertux.inc and convert everything to inc_PR supertux-qvga needed 2 things to configure tough: *depending on libsdl-gfx(supertux can build without): checking for rotozoomSurface in -lSDL_gfx... no configure: error: SDL_gfx library required * fix the following error: checking for Mix_OpenAudio in -lSDL_mixer... no configure: error: SDL_mixer library required The fix is similar to ac36d86725da867d691b16668d88f096d0b7da37 ( libsdl-mixer 1.2.11: fix libvorbis's search path ) And the cause is the same: configure:5791: arm-oe-linux-gnueabi-gcc [...] conftest.c -lSDL_mixer -lSDL -lpthread -L/usr/lib -lmikmod -ldl -lm >&5 /usr/lib/libSDL_mixer.so: file not recognized: File format not recognized collect2: ld returned 1 exit status Note that the packages were visually inspected with find in : supertux-0.1.3-r7.0/packages-split supertux-qvga-0.1.3-r7.0/packages-split PR was bumped in supertux.inc Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Diffstat (limited to 'recipes/supertux/supertux.inc')
-rw-r--r--recipes/supertux/supertux.inc33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/supertux/supertux.inc b/recipes/supertux/supertux.inc
new file mode 100644
index 0000000000..09f004ffc5
--- /dev/null
+++ b/recipes/supertux/supertux.inc
@@ -0,0 +1,33 @@
+DESCRIPTION = "SuperTux is a classic 2D jump'n'run sidescroller game \
+in a style similar to the original SuperMario games."
+SECTION = "games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+INC_PR = "r7"
+
+RDEPENDS_${PN} += "libmikmod"
+RRECOMMENDS_${PN} = "${PN}-levels-bonus1 ${PN}-levels-bonus2"
+
+APPIMAGE = "${WORKDIR}/supertux.png"
+APPDESKTOP = "${WORKDIR}/supertux.desktop"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/super-tux/supertux-${PV}.tar.bz2 \
+# http://ssel.vub.ac.be/Members/DennisWagelaar/download/zaurus/supertux-0.1.2-fp.patch.gz \
+ file://supertux.png \
+ file://install-no-overwrite.patch \
+ file://compilation-fixes.patch \
+ file://supertux.desktop \
+ "
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+EXTRA_OECONF = "--disable-opengl"
+
+inherit autotools sdl
+
+PACKAGES_prepend = " ${PN}-levels-bonus1 ${PN}-levels-bonus2 "
+FILES_${PN}-levels-bonus1 = "${datadir}/supertux/levels/bonus1 ${datadir}/supertux/levels/worldmaps/bonusisland1.stwm"
+FILES_${PN}-levels-bonus2 = "${datadir}/supertux/levels/bonus2 ${datadir}/supertux/levels/worldmaps/bonusisland2.stwm"
+FILES_${PN} += "${datadir}/supertux"
+
+SRC_URI[md5sum] = "f2fc288459f33d5cd8f645fbca737a63"
+SRC_URI[sha256sum] = "0092588351776626955339caaa62d12ce5954bb80c5f6952f60a122f53c2ad97"