aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tcltk
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-10-01 07:52:39 -0700
committerTom Rini <tom_rini@mentor.com>2010-10-01 07:52:39 -0700
commit3eb2876906c04634ed2562ce867d394828046371 (patch)
tree013af7de6744ff66769de29f607f382ff162d07c /recipes/tcltk
parentffcce548a4f93fc25530cb34502664700277bd0c (diff)
downloadopenembedded-3eb2876906c04634ed2562ce867d394828046371.tar.gz
tcl/tcl-native: Fix building when tclsh isn't on the system
We do want to change from using the tclsh we just built when building for the target but for native we want to make sure it's used. Acked-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/tcltk')
-rw-r--r--recipes/tcltk/tcl_8.5.8.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/tcltk/tcl_8.5.8.bb b/recipes/tcltk/tcl_8.5.8.bb
index 86302407c7..e98b98d29d 100644
--- a/recipes/tcltk/tcl_8.5.8.bb
+++ b/recipes/tcltk/tcl_8.5.8.bb
@@ -25,10 +25,14 @@ inherit autotools binconfig
EXTRA_OECONF = "--enable-threads"
-do_compile_prepend() {
+do_configure_append() {
echo > ../compat/fixstrtod.c
+}
+
+do_compile_prepend_pn-tcl () {
sed -i -e 's:./tclsh :tclsh :g' Makefile
}
+
do_install() {
autotools_do_install
# Stage a few extra headers to make tk happy