aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tcltk
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2010-08-30 23:50:54 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-30 13:17:16 -0700
commit6c21af6a85996ed5891925ca2221c4615048a331 (patch)
treefc6d39a33a12ecc2f590b66a88909e413d306f92 /recipes/tcltk
parent1c30732f94942fde0493d540591d7e131b748e71 (diff)
downloadopenembedded-6c21af6a85996ed5891925ca2221c4615048a331.tar.gz
tcl: Run oe-stylize.py script and modify the recipe accordingly
* Run the oe-stylize.py script on the recipe and modify the recipe according to the output of the script. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/tcltk')
-rw-r--r--recipes/tcltk/tcl_8.5.8.bb45
1 files changed, 21 insertions, 24 deletions
diff --git a/recipes/tcltk/tcl_8.5.8.bb b/recipes/tcltk/tcl_8.5.8.bb
index 9d030b9d08..e8905f0fa2 100644
--- a/recipes/tcltk/tcl_8.5.8.bb
+++ b/recipes/tcltk/tcl_8.5.8.bb
@@ -1,8 +1,7 @@
DESCRIPTION = "Tool Command Language"
-LICENSE = "tcl"
-SECTION = "devel/tcltk"
HOMEPAGE = "http://tcl.sourceforge.net"
-
+SECTION = "devel/tcltk"
+LICENSE = "tcl"
PR = "r7"
SRC_URI = "\
@@ -16,43 +15,41 @@ SRC_URI = "\
file://tclprivate.diff;striplevel=2 \
file://mips-tclstrtod.patch;striplevel=0 \
"
-
SRC_URI[md5sum] = "7f123e53b3daaaba2478d3af5a0752e3"
SRC_URI[sha256sum] = "6b090c1024038d0381e1ccfbd6d5c0f0e6ef205269ceb9d28bd7bd7ac5bbf4a7"
S = "${WORKDIR}/tcl${PV}/unix"
+SYSROOT_PREPROCESS_FUNCS =+ "tcl_sysroot"
inherit autotools binconfig
EXTRA_OECONF = "--enable-threads"
do_compile_prepend() {
- echo > ../compat/fixstrtod.c
- sed -i -e 's:./tclsh :tclsh :g' Makefile
+ echo > ../compat/fixstrtod.c
+ sed -i -e 's:./tclsh :tclsh :g' Makefile
}
-
-BINCONFIG_GLOB = "*Config.sh"
-
do_install() {
- autotools_do_install
- # Stage a few extra headers to make tk happy
- install -d ${D}${includedir}/tcl-${PV}/generic
- install -m 0644 ../generic/*.h ${D}${includedir}/tcl-${PV}/generic
- install -m 0644 *.h ${D}${includedir}/tcl-${PV}/generic
- install -d ${D}${includedir}/tcl-${PV}/unix
- install -m 0644 *Unix*.h ${D}${includedir}/tcl-${PV}/unix/
- rm -f ${D}${includedir}/regex.h
- ln -sf tclsh8.5 ${D}${bindir}/tclsh
-}
-
-SYSROOT_PREPROCESS_FUNCS =+ "tcl_sysroot"
-
-tcl_sysroot() {
- sed -i 's:/usr/include/tcl-private:${STAGING_INCDIR}/tcl-${PV}:' tclConfig.sh
+ autotools_do_install
+ # Stage a few extra headers to make tk happy
+ install -d ${D}${includedir}/tcl-${PV}/generic
+ install -m 0644 ../generic/*.h ${D}${includedir}/tcl-${PV}/generic
+ install -m 0644 *.h ${D}${includedir}/tcl-${PV}/generic
+ install -d ${D}${includedir}/tcl-${PV}/unix
+ install -m 0644 *Unix*.h ${D}${includedir}/tcl-${PV}/unix/
+ rm -f ${D}${includedir}/regex.h
+ ln -sf tclsh8.5 ${D}${bindir}/tclsh
}
PACKAGES =+ "${PN}-lib"
+
FILES_${PN}-lib = "${libdir}/libtcl8.5.so.*"
FILES_${PN} += "${libdir}/tcl*"
FILES_${PN}-dev += "${libdir}/tclConfig.sh"
+BINCONFIG_GLOB = "*Config.sh"
+
+tcl_sysroot() {
+ sed -i 's:/usr/include/tcl-private:${STAGING_INCDIR}/tcl-${PV}:' tclConfig.sh
+}
+