aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/telepathy
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-17 19:22:07 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-18 05:25:52 +0100
commit60508b874987984680573843d9e772ea55b06ce9 (patch)
treef09b692a0dd9aaca1c24fa4a149d20362cb41591 /recipes/telepathy
parent8b6d84221426d0b5cb54b8877dd0f70e796a3811 (diff)
downloadopenembedded-60508b874987984680573843d9e772ea55b06ce9.tar.gz
empathy: add 2.28.2
gnome-doc-utils: add 0.19.2 telepathy-glib: add 0.7.37
Diffstat (limited to 'recipes/telepathy')
-rw-r--r--recipes/telepathy/empathy/fix-xml-threadbreakage.patch81
-rw-r--r--recipes/telepathy/empathy_2.28.2.bb24
-rw-r--r--recipes/telepathy/telepathy-glib_0.7.37.bb12
3 files changed, 117 insertions, 0 deletions
diff --git a/recipes/telepathy/empathy/fix-xml-threadbreakage.patch b/recipes/telepathy/empathy/fix-xml-threadbreakage.patch
new file mode 100644
index 0000000000..17077f78ea
--- /dev/null
+++ b/recipes/telepathy/empathy/fix-xml-threadbreakage.patch
@@ -0,0 +1,81 @@
+From: Guillaume Desmottes <guillaume.desmottes@collabora.co.uk>
+Date: Wed, 13 Jan 2010 10:28:29 +0000 (+0000)
+Subject: Call xmlCleanupParser() only once when exiting (#600693)
+X-Git-Url: http://git.collabora.co.uk/?p=user%2Fcassidy%2Fempathy;a=commitdiff_plain;h=9ab430b106fb724e63a201eff3d391214650f279
+
+Call xmlCleanupParser() only once when exiting (#600693)
+
+This function should only be called when exiting the application as it cleans
+up the memory allocated by the library itself.
+
+Thanks to Lennart for pointing this out.
+---
+
+diff --git a/libempathy-gtk/empathy-plist.c b/libempathy-gtk/empathy-plist.c
+index 4cc392b..73d3146 100644
+--- a/libempathy-gtk/empathy-plist.c
++++ b/libempathy-gtk/empathy-plist.c
+@@ -294,7 +294,6 @@ empathy_plist_parse_from_file (const char *filename)
+ parsed_doc = empathy_plist_parse (root_element);
+
+ xmlFreeDoc (doc);
+- xmlCleanupParser ();
+
+ return parsed_doc;
+ }
+@@ -329,7 +328,6 @@ empathy_plist_parse_from_memory (const char *data, gsize len)
+ parsed_doc = empathy_plist_parse (root_element);
+
+ xmlFreeDoc (doc);
+- xmlCleanupParser ();
+
+ return parsed_doc;
+ }
+diff --git a/libempathy/empathy-chatroom-manager.c b/libempathy/empathy-chatroom-manager.c
+index 7d80b94..0f06132 100644
+--- a/libempathy/empathy-chatroom-manager.c
++++ b/libempathy/empathy-chatroom-manager.c
+@@ -123,7 +123,6 @@ chatroom_manager_file_save (EmpathyChatroomManager *manager)
+ xmlSaveFormatFileEnc (priv->file, doc, "utf-8", 1);
+ xmlFreeDoc (doc);
+
+- xmlCleanupParser ();
+ xmlMemoryDump ();
+
+ return TRUE;
+diff --git a/libempathy/empathy-contact-groups.c b/libempathy/empathy-contact-groups.c
+index 22d81d0..9ddc562 100644
+--- a/libempathy/empathy-contact-groups.c
++++ b/libempathy/empathy-contact-groups.c
+@@ -220,7 +220,6 @@ contact_groups_file_save (void)
+ xmlSaveFormatFileEnc (file, doc, "utf-8", 1);
+ xmlFreeDoc (doc);
+
+- xmlCleanupParser ();
+ xmlMemoryDump ();
+
+ g_free (file);
+diff --git a/libempathy/empathy-irc-network-manager.c b/libempathy/empathy-irc-network-manager.c
+index ad72680..8170a5f 100644
+--- a/libempathy/empathy-irc-network-manager.c
++++ b/libempathy/empathy-irc-network-manager.c
+@@ -712,7 +712,6 @@ irc_network_manager_file_save (EmpathyIrcNetworkManager *self)
+ xmlSaveFormatFileEnc (priv->user_file, doc, "utf-8", 1);
+ xmlFreeDoc (doc);
+
+- xmlCleanupParser ();
+ xmlMemoryDump ();
+
+ priv->have_to_save = FALSE;
+diff --git a/src/empathy.c b/src/empathy.c
+index 82f62dd..9665405 100644
+--- a/src/empathy.c
++++ b/src/empathy.c
+@@ -1005,6 +1005,7 @@ main (int argc, char *argv[])
+ g_object_unref (unique_app);
+
+ notify_uninit ();
++ xmlCleanupParser ();
+
+ return EXIT_SUCCESS;
+ }
diff --git a/recipes/telepathy/empathy_2.28.2.bb b/recipes/telepathy/empathy_2.28.2.bb
new file mode 100644
index 0000000000..c1e715f433
--- /dev/null
+++ b/recipes/telepathy/empathy_2.28.2.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "libcanberra telepathy-farsight gnome-doc-utils python-native telepathy-python telepathy-mission-control libtelepathy telepathy-glib gtk+ gconf libglade eds-dbus"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+inherit gnome
+
+SRC_URI += "file://fix-xml-threadbreakage.patch;patch=1"
+
+PARALLEL_MAKE = ""
+
+PACKAGES =+ "empathy-scrollkeeper-junk"
+FILES_empathy-scrollkeeper-junk = "/var/lib/scrollkeeper"
+
+FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/telepathy/ \
+ ${datadir}/icons \
+ ${libdir}/python*"
+
+FILES_${PN}-dbg += "${libdir}/python*/*/.debug"
+
diff --git a/recipes/telepathy/telepathy-glib_0.7.37.bb b/recipes/telepathy/telepathy-glib_0.7.37.bb
new file mode 100644
index 0000000000..05c27abca2
--- /dev/null
+++ b/recipes/telepathy/telepathy-glib_0.7.37.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Telepathy framework - GLib library"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus libxslt-native python-native dbus-native"
+LICENSE = "LGPL"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz "
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+