aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorNaresh Medisetty <naresh@ti.com>2010-12-20 22:48:53 +0000
committerKhem Raj <raj.khem@gmail.com>2010-12-20 22:31:56 -0800
commit14e4ab4a55dc9cdef0c4e705d7c50c0e36707020 (patch)
tree20719a6396ad1383e4467eeafec6cfd13292d976 /recipes/ti
parentd7b7f6398250f37e5db22a3565836c3b5f4997cc (diff)
downloadopenembedded-14e4ab4a55dc9cdef0c4e705d7c50c0e36707020.tar.gz
lftb: add ti LFTB recipe
* This package contains functional test suites for TI devices used to verify the Linux kernel and drivers for the various peripherals found on TI devices. Signed-off-by: Naresh Medisetty <naresh@ti.com> Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-lftb.inc46
-rw-r--r--recipes/ti/ti-lftb_2.0.bb9
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes/ti/ti-lftb.inc b/recipes/ti/ti-lftb.inc
new file mode 100644
index 0000000000..166d2d271b
--- /dev/null
+++ b/recipes/ti/ti-lftb.inc
@@ -0,0 +1,46 @@
+DESCRIPTION = "Linux Functional Test Bench"
+HOMEPAGE = "http://arago-project.org/git/projects/?p=test-automation/target-code/psp/lftb.git;a=summary"
+LICENSE="BSD"
+
+INC_PR = "r0"
+
+DEPENDS = "virtual/kernel"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "(dm365|dm355|dm6446|dm6467|omapl137|omapl138|omap3|ti816x)"
+
+S = "${WORKDIR}/git"
+
+#Machine specific overrides
+PLATFORM_omap3evm="omap35x"
+PLATFORM_am180x-evm="am18x"
+PLATFORM_am3517-evm="am3517"
+PLATFORM_am37x-evm="am37x"
+PLATFORM_beagleboard="beagle"
+PLATFORM_da830-omapl137-evm="am17x"
+PLATFORM_da850-omapl138-evm="am18x"
+PLATFORM_am181x-evm="am18x"
+PLATFORM_dm355-evm="dm355"
+PLATFORM_dm365-evm="dm365"
+PLATFORM_dm37x-evm="am37x"
+PLATFORM_dm6446-evm="dm644x"
+PLATFORM_dm6467-evm="dm646x"
+PLATFORM_ti816x="ti816x"
+
+do_compile() {
+ cd ${S}
+ make KERNEL_DIR=${STAGING_KERNEL_DIR} PLATFORM=${PLATFORM} TOOL_PREFIX=${TARGET_PREFIX}
+}
+
+do_install() {
+ install -d ${D}${bindir}/lftb
+ make INSTALL_DIR=${D}${bindir}/lftb install
+
+ # Remove unneeded tarball placed in bindir by install target
+ rm -rf ${D}${bindir}/lftb.tar.gz
+}
+
+INSANE_SKIP_${PN} = True
+
+FILES_${PN} = "${bindir}/lftb"
diff --git a/recipes/ti/ti-lftb_2.0.bb b/recipes/ti/ti-lftb_2.0.bb
new file mode 100644
index 0000000000..62c936c2b9
--- /dev/null
+++ b/recipes/ti/ti-lftb_2.0.bb
@@ -0,0 +1,9 @@
+require ti-lftb.inc
+
+SRCREV = "3d0be58aee659ef7e8eda43e916172bab300235f"
+
+PR = "${MACHINE_KERNEL_PR}+${INC_PR}"
+PR_append = "a"
+
+SRC_URI = "git://arago-project.org/git/projects/test-automation/target-code/psp/lftb.git;protocol=git \
+"