aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u2nl/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/u2nl/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/u2nl/files')
-rw-r--r--recipes/u2nl/files/buildsystem.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/u2nl/files/buildsystem.patch b/recipes/u2nl/files/buildsystem.patch
new file mode 100644
index 0000000000..9de58fa435
--- /dev/null
+++ b/recipes/u2nl/files/buildsystem.patch
@@ -0,0 +1,32 @@
+Index: u2nl-1.3/Makefile
+===================================================================
+--- u2nl-1.3.orig/Makefile 2005-01-03 19:31:20.000000000 +0100
++++ u2nl-1.3/Makefile 2006-12-14 12:38:15.052227000 +0100
+@@ -1,5 +1,25 @@
++CC = gcc
++CFLAGS = -Wall -g
++LDFLAGS =
++
++DESTDIR =
++prefix = /usr/local
++bindir = $(prefix)/bin
++
++INSTALL_BIN = install -m 0755
++INSTALL_DIR = install -d
++
+ all: u2nl
+
+ u2nl: u2nl.c
+- gcc -Wall -g u2nl.c -o u2nl
+-
++ $(CC) $(CFLAGS) $(LDFLAGS) u2nl.c -o u2nl
++
++install:
++ $(INSTALL_DIR) $(DESTDIR)$(bindir)
++ $(INSTALL_BIN) u2nl $(DESTDIR)$(bindir)/u2nl
++
++uninstall:
++ -rm -f $(DESTDIR)$(bindir)/u2nl
++
++clean:
++ -rm -fR u2nl