aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/uclibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-03-14 22:47:46 -0700
committerKhem Raj <raj.khem@gmail.com>2011-03-14 22:48:24 -0700
commitf3ef166dca255f2e8518bb03655332273b1ef074 (patch)
tree4f3721d0f712ecd944926ddc47de4cf4f6e92199 /recipes/uclibc
parent6c687a855ecd63405bae954bcd12b5660ed94a1e (diff)
downloadopenembedded-f3ef166dca255f2e8518bb03655332273b1ef074.tar.gz
uclibc_git: Upgrade to latest 0.9.32 snapshot
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/uclibc')
-rwxr-xr-xrecipes/uclibc/uclibc-git/remove-eabi-oabi-selection.patch123
-rwxr-xr-xrecipes/uclibc/uclibc-git/transform-eabi-oabi-choice.patch74
-rw-r--r--recipes/uclibc/uclibc_git.bb2
3 files changed, 85 insertions, 114 deletions
diff --git a/recipes/uclibc/uclibc-git/remove-eabi-oabi-selection.patch b/recipes/uclibc/uclibc-git/remove-eabi-oabi-selection.patch
index cc735a5502..8f3464e2e4 100755
--- a/recipes/uclibc/uclibc-git/remove-eabi-oabi-selection.patch
+++ b/recipes/uclibc/uclibc-git/remove-eabi-oabi-selection.patch
@@ -40,77 +40,52 @@ Cc: Carmelo AMOROSO <carmelo.amoroso@st.com>
libc/sysdeps/linux/arm/bits/huge_val.h | 4 ++--
3 files changed, 9 insertions(+), 15 deletions(-)
-diff --git a/extra/Configs/Config.arm b/extra/Configs/Config.arm
-index 9aa9e56..85f2515 100644
---- a/extra/Configs/Config.arm
-+++ b/extra/Configs/Config.arm
-@@ -12,17 +12,6 @@ config FORCE_OPTIONS_FOR_ARCH
- default y
- select ARCH_ANY_ENDIAN
-
--config CONFIG_ARM_EABI
-- bool "Build for EABI"
-- help
-- If you say 'y' here, functions and constants required by the
-- ARM EABI will be built into the library. You should say 'y'
-- if your compiler uses the ARM EABI, in which case you will also
-- need a kernel supporting the EABI system call interface.
--
-- If you say 'n' here, then the library will be built for the
-- old Linux ABI.
--
- config COMPILE_IN_THUMB_MODE
- bool "Build using Thumb mode"
- select USE_BX
-diff --git a/libc/sysdeps/linux/arm/Makefile.arch b/libc/sysdeps/linux/arm/Makefile.arch
-index b53c539..14279e0 100644
---- a/libc/sysdeps/linux/arm/Makefile.arch
-+++ b/libc/sysdeps/linux/arm/Makefile.arch
-@@ -24,7 +24,12 @@ ifeq ($(UCLIBC_HAS_ADVANCED_REALTIME),y)
- CSRC += posix_fadvise.c posix_fadvise64.c
- endif
-
--ifeq ($(CONFIG_ARM_EABI),y)
-+# Is our compiler set up for EABI ?
-+IS_EABI:=$(shell $(CC) $(CFLAGS) -x c - -E -dM </dev/null 2>/dev/null \
-+ |sed -r -e '/^\#[[:space:]]*define[[:space:]]+__ARM_EABI__([[:space:]]+1)?$$/!d; s/.+/y/;' \
-+ )
-+
-+ifeq ($(IS_EABI),y)
- CSRC += aeabi_assert.c aeabi_atexit.c aeabi_errno_addr.c \
- aeabi_localeconv.c aeabi_memclr.c aeabi_memcpy.c \
- aeabi_memmove.c aeabi_memset.c find_exidx.c
-@@ -37,7 +42,7 @@ else
- CSRC += syscall.c
- endif
-
--ifeq ($(CONFIG_ARM_EABI),y)
-+ifeq ($(IS_EABI),y)
- libc-static-y += $(ARCH_OUT)/aeabi_lcsts.o $(ARCH_OUT)/aeabi_math.o \
- $(ARCH_OUT)/aeabi_sighandlers.o
- libc-nonshared-y += $(ARCH_OUT)/aeabi_lcsts.os $(ARCH_OUT)/aeabi_math.os \
-diff --git a/libc/sysdeps/linux/arm/bits/huge_val.h b/libc/sysdeps/linux/arm/bits/huge_val.h
-index a215f3c..745e0bb 100644
---- a/libc/sysdeps/linux/arm/bits/huge_val.h
-+++ b/libc/sysdeps/linux/arm/bits/huge_val.h
-@@ -32,7 +32,7 @@
- # define HUGE_VAL (__extension__ 0x1.0p2047)
- #elif defined __GNUC__
-
--#ifndef __CONFIG_ARM_EABI__
-+#ifndef __ARM_EABI__
- # define HUGE_VAL \
- (__extension__ \
- ((union { unsigned __l __attribute__((__mode__(__DI__))); double __d; }) \
-@@ -50,7 +50,7 @@
-
- typedef union { unsigned char __c[8]; double __d; } __huge_val_t;
-
--#ifndef __CONFIG_ARM_EABI__
-+#ifndef __ARM_EABI__
- # if __BYTE_ORDER == __BIG_ENDIAN
- # define __HUGE_VAL_bytes { 0, 0, 0, 0, 0x7f, 0xf0, 0, 0 }
- # endif
---
-1.7.1
-
+Index: git/libc/sysdeps/linux/arm/Makefile.arch
+===================================================================
+--- git.orig/libc/sysdeps/linux/arm/Makefile.arch
++++ git/libc/sysdeps/linux/arm/Makefile.arch
+@@ -24,7 +24,12 @@ ifeq ($(UCLIBC_HAS_ADVANCED_REALTIME),y)
+ CSRC += posix_fadvise.c posix_fadvise64.c
+ endif
+
+-ifeq ($(CONFIG_ARM_EABI),y)
++# Is our compiler set up for EABI ?
++IS_EABI:=$(shell $(CC) $(CFLAGS) -x c - -E -dM </dev/null 2>/dev/null \
++ |sed -r -e '/^\#[[:space:]]*define[[:space:]]+__ARM_EABI__([[:space:]]+1)?$$/!d; s/.+/y/;' \
++ )
++
++ifeq ($(IS_EABI),y)
+ CSRC += aeabi_assert.c aeabi_atexit.c aeabi_errno_addr.c \
+ aeabi_localeconv.c aeabi_memclr.c aeabi_memcpy.c \
+ aeabi_memmove.c aeabi_memset.c find_exidx.c
+@@ -37,7 +42,7 @@ else
+ CSRC += syscall.c
+ endif
+
+-ifeq ($(CONFIG_ARM_EABI),y)
++ifeq ($(IS_EABI),y)
+ libc-static-y += $(ARCH_OUT)/aeabi_lcsts.o $(ARCH_OUT)/aeabi_math.o \
+ $(ARCH_OUT)/aeabi_sighandlers.o
+ libc-nonshared-y += $(ARCH_OUT)/aeabi_lcsts.os $(ARCH_OUT)/aeabi_math.os \
+Index: git/libc/sysdeps/linux/arm/bits/huge_val.h
+===================================================================
+--- git.orig/libc/sysdeps/linux/arm/bits/huge_val.h
++++ git/libc/sysdeps/linux/arm/bits/huge_val.h
+@@ -32,7 +32,7 @@
+ # define HUGE_VAL (__extension__ 0x1.0p2047)
+ #elif defined __GNUC__
+
+-#ifndef __CONFIG_ARM_EABI__
++#ifndef __ARM_EABI__
+ # define HUGE_VAL \
+ (__extension__ \
+ ((union { unsigned __l __attribute__((__mode__(__DI__))); double __d; }) \
+@@ -50,7 +50,7 @@
+
+ typedef union { unsigned char __c[8]; double __d; } __huge_val_t;
+
+-#ifndef __CONFIG_ARM_EABI__
++#ifndef __ARM_EABI__
+ # if __BYTE_ORDER == __BIG_ENDIAN
+ # define __HUGE_VAL_bytes { 0, 0, 0, 0, 0x7f, 0xf0, 0, 0 }
+ # endif
diff --git a/recipes/uclibc/uclibc-git/transform-eabi-oabi-choice.patch b/recipes/uclibc/uclibc-git/transform-eabi-oabi-choice.patch
index cef8042ed0..82970ca458 100755
--- a/recipes/uclibc/uclibc-git/transform-eabi-oabi-choice.patch
+++ b/recipes/uclibc/uclibc-git/transform-eabi-oabi-choice.patch
@@ -34,42 +34,38 @@ Cc: Carmelo AMOROSO <carmelo.amoroso@st.com>
extra/Configs/Config.arm | 23 ++++++++---------------
1 files changed, 8 insertions(+), 15 deletions(-)
-diff --git a/extra/Configs/Config.arm b/extra/Configs/Config.arm
-index 6c75a00..227b90c 100644
---- a/extra/Configs/Config.arm
-+++ b/extra/Configs/Config.arm
-@@ -12,23 +12,16 @@ config FORCE_OPTIONS_FOR_ARCH
- default y
- select ARCH_ANY_ENDIAN
-
--choice
-- prompt "Target ABI"
-- default CONFIG_ARM_OABI
-+config CONFIG_ARM_EABI
-+ bool "Build for EABI"
- help
-- If you choose "EABI" here, functions and constants required by the
-- ARM EABI will be built into the library. You should choose "EABI"
-+ If you say 'y' here, functions and constants required by the
-+ ARM EABI will be built into the library. You should say 'y'
- if your compiler uses the ARM EABI, in which case you will also
-- need a kernel supporting the EABI system call interface, or "OABI"
-- for a compiler using the old Linux ABI.
--
--config CONFIG_ARM_OABI
-- bool "OABI"
--
--config CONFIG_ARM_EABI
-- bool "EABI"
--
--endchoice
-+ need a kernel supporting the EABI system call interface.
-+
-+ If you say 'n' here, then the library will be built for the
-+ old Linux ABI.
-
- config COMPILE_IN_THUMB_MODE
- bool "Build using Thumb mode"
---
-1.7.1
-
+Index: git/extra/Configs/Config.arm
+===================================================================
+--- git.orig/extra/Configs/Config.arm
++++ git/extra/Configs/Config.arm
+@@ -12,23 +12,16 @@ config FORCE_OPTIONS_FOR_ARCH
+ default y
+ select ARCH_ANY_ENDIAN
+
+-choice
+- prompt "Target ABI"
+- default CONFIG_ARM_EABI
++config CONFIG_ARM_EABI
++ bool "Build for EABI"
+ help
+- If you choose "EABI" here, functions and constants required by the
+- ARM EABI will be built into the library. You should choose "EABI"
++ If you say 'y' here, functions and constants required by the
++ ARM EABI will be built into the library. You should say 'y'
+ if your compiler uses the ARM EABI, in which case you will also
+- need a kernel supporting the EABI system call interface, or "OABI"
+- for a compiler using the old Linux ABI.
+-
+-config CONFIG_ARM_OABI
+- bool "OABI"
+-
+-config CONFIG_ARM_EABI
+- bool "EABI"
++ need a kernel supporting the EABI system call interface.
+
+-endchoice
++ If you say 'n' here, then the library will be built for the
++ old Linux ABI.
+
+ config COMPILE_IN_THUMB_MODE
+ bool "Build using Thumb mode"
diff --git a/recipes/uclibc/uclibc_git.bb b/recipes/uclibc/uclibc_git.bb
index c24dbc2255..d3118e58ed 100644
--- a/recipes/uclibc/uclibc_git.bb
+++ b/recipes/uclibc/uclibc_git.bb
@@ -7,7 +7,7 @@
# on whether the base patches apply to the selected (SRCDATE) svn release.
#
UCLIBC_BASE ?= "0.9.32"
-SRCREV="094d82d3b3e8f8c8460a802b7a9548f3ae4fda46"
+SRCREV="e25a95a7a3c9f5bb3a38106422b12f83bf58d119"
PR_append = "+gitr${SRCPV}"
DEFAULT_PREFERENCE = "-1"
#DEFAULT_PREFERENCE is 0 (empty), releases have a preference of 1 so take