aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udev/udev_141.bb
diff options
context:
space:
mode:
authorDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-12-17 18:37:22 +0100
committerDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-12-25 17:22:41 +0100
commit7e15a70457ea2f1327162d0a3050c7e6eb95975c (patch)
tree284259121699d3e2af62892b13faf76d1a41a67e /recipes/udev/udev_141.bb
parent2713d4ef07b71284632c251a0ce9f3d652700019 (diff)
downloadopenembedded-7e15a70457ea2f1327162d0a3050c7e6eb95975c.tar.gz
udev-141: added support for buglabs's bug device
The udev configurations files are needed for Xorg configuration for buglabs's bug device that will be commited later, in order to find the right device nodes for the touchscreens Note that the script creating the bmi(Bug module interface) event pipe has not been commented out,because it will be needed when the java bindings for the bug device will be in openembedded The udev rules were took from buglabs svn: svn://svn.buglabs.net/bug/branches/hrw/oe-stable-2009/ inside they are in meta-bug/packages/udev-rules/bug-udev/
Diffstat (limited to 'recipes/udev/udev_141.bb')
-rw-r--r--recipes/udev/udev_141.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/recipes/udev/udev_141.bb b/recipes/udev/udev_141.bb
index e07150df65..00ba97102d 100644
--- a/recipes/udev/udev_141.bb
+++ b/recipes/udev/udev_141.bb
@@ -6,7 +6,7 @@ LICENSE = "GPL"
# Untested
DEFAULT_PREFERENCE = "-1"
-PR = "r18"
+PR = "r19"
# needed for init.d script
RDEPENDS_${PN} += "udev-utils"
@@ -29,6 +29,14 @@ SRC_URI += " \
SRC_URI_append_h2200 = " file://50-hostap_cs.rules "
PACKAGE_ARCH_h2200 = "h2200"
+#buglabs's bug device
+SRC_URI_append_bug = " \
+ file://30-BUG.rules \
+ file://10-mx31.rules \
+ file://bmi_eventpipe.sh "
+
+PACKAGE_ARCH_bug = "bug"
+
inherit update-rc.d autotools_stage
# Put stuff in /lib and /sbin
@@ -98,6 +106,12 @@ do_install_append_h2200() {
install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
}
+do_install_append_bug() {
+ install -m 0644 ${WORKDIR}/30-BUG.rules ${D}${sysconfdir}/udev/rules.d/30-BUG.rules
+ install -m 0644 ${WORKDIR}/10-mx31.rules ${D}${sysconfdir}/udev/rules.d/10-mx31.rules
+ install -m 0644 ${WORKDIR}/bmi_eventpipe.sh ${D}${sysconfdir}/udev/scripts/bmi_eventpipe.sh
+}
+
pkg_postinst_${PN}_append() {
if [ -d $D/lib/udev/rules.d ] ; then
echo "$D/lib/udev/rules.d is not a symlink, fixing that"