aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udhcp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/udhcp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/udhcp')
-rw-r--r--recipes/udhcp/files/gcc3.patch15
-rw-r--r--recipes/udhcp/files/install.patch64
-rw-r--r--recipes/udhcp/files/nostrip.patch30
-rw-r--r--recipes/udhcp/udhcp_0.9.8.bb29
4 files changed, 138 insertions, 0 deletions
diff --git a/recipes/udhcp/files/gcc3.patch b/recipes/udhcp/files/gcc3.patch
new file mode 100644
index 0000000000..a39f42a7bd
--- /dev/null
+++ b/recipes/udhcp/files/gcc3.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udhcp-0.9.8/dhcpc.c~gcc3
++++ udhcp-0.9.8/dhcpc.c
+@@ -132,6 +132,7 @@
+ state = INIT_SELECTING;
+ break;
+ case INIT_SELECTING:
++ ;
+ }
+
+ /* start things over */
diff --git a/recipes/udhcp/files/install.patch b/recipes/udhcp/files/install.patch
new file mode 100644
index 0000000000..7cec1c087f
--- /dev/null
+++ b/recipes/udhcp/files/install.patch
@@ -0,0 +1,64 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udhcp-0.9.8/Makefile~install.patch
++++ udhcp-0.9.8/Makefile
+@@ -1,10 +1,11 @@
+ # udhcp makefile
+
++DESTDIR=
+ prefix=/usr
+-SBINDIR=/sbin
+-USRSBINDIR=${prefix}/sbin
+-USRBINDIR=${prefix}/bin
+-USRSHAREDIR=${prefix}/share
++sbindir=/sbin
++usrsbindir=$(prefix)/sbin
++usrbindir=$(prefix)/bin
++datadir=$(prefix)/share
+
+ # Uncomment this to get a shared binary. Call as udhcpd for the server,
+ # and udhcpc for the client
+@@ -81,25 +82,27 @@
+
+
+ install: all
+-
+- $(INSTALL) $(DAEMONS) $(USRSBINDIR)
+- $(INSTALL) $(COMMANDS) $(USRBINDIR)
++ $(INSTALL) -d $(DESTDIR)$(usrsbindir)
++ $(INSTALL) $(DAEMONS) $(DESTDIR)$(usrsbindir)
++ $(INSTALL) -d $(DESTDIR)$(usrbindir)
++ $(INSTALL) $(COMMANDS) $(DESTDIR)$(usrbindir)
++ $(INSTALL) -d $(DESTDIR)$(sbindir)
+ ifdef COMBINED_BINARY
+- ln -sf $(USRSBINDIR)/$(DAEMONS) $(SBINDIR)/$(BOOT_PROGRAMS)
++ ln -sf $(usrsbindir)/$(DAEMONS) $(DESTDIR)$(sbindir)/$(BOOT_PROGRAMS)
+ else
+- $(INSTALL) $(BOOT_PROGRAMS) $(SBINDIR)
++ $(INSTALL) $(BOOT_PROGRAMS) $(DESTDIR)$(sbindir)
+ endif
+- mkdir -p $(USRSHAREDIR)/udhcpc
++ $(INSTALL) -d $(DESTDIR)$(datadir)/udhcpc
+ for name in bound deconfig renew script ; do \
+ $(INSTALL) samples/sample.$$name \
+- $(USRSHAREDIR)/udhcpc/default.$$name ; \
++ $(DESTDIR)$(datadir)/udhcpc/default.$$name ; \
+ done
+- mkdir -p $(USRSHAREDIR)/man/man1
+- $(INSTALL) dumpleases.1 $(USRSHAREDIR)/man/man1
+- mkdir -p $(USRSHAREDIR)/man/man5
+- $(INSTALL) udhcpd.conf.5 $(USRSHAREDIR)/man/man5
+- mkdir -p $(USRSHAREDIR)/man/man8
+- $(INSTALL) udhcpc.8 udhcpd.8 $(USRSHAREDIR)/man/man8
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man1
++ $(INSTALL) dumpleases.1 $(DESTDIR)$(mandir)/man1
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man5
++ $(INSTALL) udhcpd.conf.5 $(DESTDIR)$(mandir)/man5
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
++ $(INSTALL) udhcpc.8 udhcpd.8 $(DESTDIR)$(mandir)/man8
+
+ clean:
+ -rm -f udhcpd udhcpc dumpleases *.o core
diff --git a/recipes/udhcp/files/nostrip.patch b/recipes/udhcp/files/nostrip.patch
new file mode 100644
index 0000000000..7c8af095cc
--- /dev/null
+++ b/recipes/udhcp/files/nostrip.patch
@@ -0,0 +1,30 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udhcp-0.9.8/Makefile~nostrip
++++ udhcp-0.9.8/Makefile
+@@ -24,7 +24,6 @@
+
+ VER := 0.9.8
+
+-
+ OBJS_SHARED = options.o socket.o packet.o pidfile.o
+ DHCPD_OBJS = dhcpd.o arpping.o files.o leases.o serverpacket.o
+ DHCPC_OBJS = dhcpc.o clientpacket.o script.o
+@@ -56,14 +55,11 @@
+
+ ifdef DEBUG
+ CFLAGS += -g -DDEBUG
+-STRIP=true
+ else
+ CFLAGS += -Os -fomit-frame-pointer
+-STRIP=$(CROSS_COMPILE)strip
+ endif
+
+ all: $(EXEC1) $(EXEC2) $(EXEC3)
+- $(STRIP) --remove-section=.note --remove-section=.comment $(EXEC1) $(EXEC2) $(EXEC3)
+
+ $(OBJS1) $(OBJS2) $(OBJS3): *.h Makefile
+ $(EXEC1) $(EXEC2) $(EXEC3): Makefile
diff --git a/recipes/udhcp/udhcp_0.9.8.bb b/recipes/udhcp/udhcp_0.9.8.bb
new file mode 100644
index 0000000000..40487efe84
--- /dev/null
+++ b/recipes/udhcp/udhcp_0.9.8.bb
@@ -0,0 +1,29 @@
+SECTION = "console/network"
+DESCRIPTION = "Small dhcp client and dhcp server. Designed for embedded use."
+HOMEPAGE = "http://udhcp.busybox.net/"
+LICENSE = "GPL"
+
+SRC_URI = "http://udhcp.busybox.net/source/udhcp-${PV}.tar.gz \
+ file://install.patch;patch=1 \
+ file://nostrip.patch;patch=1 \
+ file://gcc3.patch;patch=1"
+
+inherit autotools
+
+CFLAGS =+ "-UDEFAULT_SCRIPT -DDEFAULT_SCRIPT=\"${datadir}/udhcpc/default.script\" \
+ -DVERSION=\"${PV}\""
+EXTRA_OEMAKE = "'CC=${CC}' 'LD=${CCLD}' \
+ 'CFLAGS=${CFLAGS}' 'LDFLAGS=${LDFLAGS}' \
+ 'prefix=${prefix}' 'sbindir=/sbin' \
+ 'usrsbindir=${sbindir}' \
+ 'usrbindir=${bindir}' \
+ 'datadir=${datadir}'"
+
+PACKAGES = "${PN}-dbg udhcpc udhcpc-doc udhcpd udhcpd-doc ${PN}"
+FILES_udhcpc = "/sbin/udhcpc ${datadir}/udhcpc"
+FILES_udhcpc-doc = "${mandir}/man8/udhcpc.8"
+FILES_udhcpd = "${sbindir}/udhcpd \
+ ${bindir}/dumpleases"
+FILES_udhcpd-doc = "${mandir}/man1/dumpleases.1 \
+ ${mandir}/man8/udhcpd.8 \
+ ${mandir}/man5/udhcpd.conf.5"