aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/unrar
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/unrar
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/unrar')
-rw-r--r--recipes/unrar/unrar-native_3.4.3.bb14
-rw-r--r--recipes/unrar/unrar.inc7
-rw-r--r--recipes/unrar/unrar_3.4.3.bb6
3 files changed, 27 insertions, 0 deletions
diff --git a/recipes/unrar/unrar-native_3.4.3.bb b/recipes/unrar/unrar-native_3.4.3.bb
new file mode 100644
index 0000000000..4b87691e89
--- /dev/null
+++ b/recipes/unrar/unrar-native_3.4.3.bb
@@ -0,0 +1,14 @@
+require unrar.inc
+inherit native
+
+do_stage() {
+ install unrar ${STAGING_BINDIR}
+}
+
+do_package() {
+ :
+}
+
+do_install() {
+ :
+}
diff --git a/recipes/unrar/unrar.inc b/recipes/unrar/unrar.inc
new file mode 100644
index 0000000000..4887ac9fb2
--- /dev/null
+++ b/recipes/unrar/unrar.inc
@@ -0,0 +1,7 @@
+SRC_URI = "http://www.rarlab.com/rar/unrarsrc-${PV}.tar.gz"
+S = "${WORKDIR}/unrar"
+
+do_compile() {
+ oe_runmake -f makefile.unix
+}
+
diff --git a/recipes/unrar/unrar_3.4.3.bb b/recipes/unrar/unrar_3.4.3.bb
new file mode 100644
index 0000000000..39d81990e2
--- /dev/null
+++ b/recipes/unrar/unrar_3.4.3.bb
@@ -0,0 +1,6 @@
+require unrar.inc
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 unrar ${D}${bindir}
+}