aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ushare
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ushare
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ushare')
-rw-r--r--recipes/ushare/ushare_0.9.7.bb9
-rw-r--r--recipes/ushare/ushare_1.1a.bb20
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes/ushare/ushare_0.9.7.bb b/recipes/ushare/ushare_0.9.7.bb
new file mode 100644
index 0000000000..b5b2d1f4bc
--- /dev/null
+++ b/recipes/ushare/ushare_0.9.7.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "ushare is a UPnP media server"
+LICENSE = "GPL"
+HOMEPAGE = "http://ushare.geexbox.org/"
+DEPENDS = "libupnp virtual/libiconv virtual/libintl"
+SRC_URI = "http://ushare.geexbox.org/releases/ushare-0.9.7.tar.bz2"
+S = "${WORKDIR}/ushare-${PV}"
+PR = "r1"
+
+inherit autotools
diff --git a/recipes/ushare/ushare_1.1a.bb b/recipes/ushare/ushare_1.1a.bb
new file mode 100644
index 0000000000..b198d89c95
--- /dev/null
+++ b/recipes/ushare/ushare_1.1a.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "ushare is a UPnP media server"
+LICENSE = "GPL"
+HOMEPAGE = "http://ushare.geexbox.org/"
+DEPENDS = "libupnp virtual/libiconv virtual/libintl"
+SRC_URI = "http://ushare.geexbox.org/releases/ushare-${PV}.tar.bz2"
+S = "${WORKDIR}/ushare-${PV}"
+
+inherit autotools gettext
+
+# the configure script is hand-crafted, it rejects some of the usual
+# configure arguments
+do_configure () {
+ ${S}/configure \
+ --prefix=${prefix} \
+ --bindir=${bindir} \
+ --localedir=${datadir}/locale \
+ --sysconfdir=${sysconfdir} \
+ --cross-compile
+}
+