aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/void11/void11_0.2.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/void11/void11_0.2.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/void11/void11_0.2.0.bb')
-rw-r--r--recipes/void11/void11_0.2.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/void11/void11_0.2.0.bb b/recipes/void11/void11_0.2.0.bb
new file mode 100644
index 0000000000..2f4d5f2af9
--- /dev/null
+++ b/recipes/void11/void11_0.2.0.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "void11"
+HOMEPAGE = "http://www.wlsec.net/void11"
+SECTION = "console/network"
+LICENSE = "GPL"
+FILES_${PN} += "${libdir}/libvoid11.so"
+
+SRC_URI = "http://www.wirelessdefence.org/Contents/Files/void11-0.2.0.tar.bz2;md5sum=1c5b3e3e70916de74c2932c7f3e46d9e \
+ http://hostap.epitest.fi/releases/hostapd-0.1.3.tar.gz;md5sum=54563fb51f143c4bf26ddec2516e8f9f \
+ file://oezc.patch;patch=1;pnum=1"
+
+S = "${WORKDIR}/void11-0.2.0"
+
+inherit autotools
+
+do_compile () {
+ oe_runmake USECONSOLE=1 HOSTAPD_PATH=${WORKDIR}/hostapd-0.1.3
+}
+
+do_install () {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${libdir}
+ install -m 0755 lib/libvoid11.so ${D}/${libdir}
+ install -m 0755 console/void11_hopper ${D}/${sbindir}
+ install -m 0755 smallsleep/smallsleep ${D}/${sbindir}
+ install -m 0755 console/void11_penetration ${D}/${sbindir}
+}