aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wifistix/wifistix-modules_5.0.16.p0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wifistix/wifistix-modules_5.0.16.p0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wifistix/wifistix-modules_5.0.16.p0.bb')
-rw-r--r--recipes/wifistix/wifistix-modules_5.0.16.p0.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes/wifistix/wifistix-modules_5.0.16.p0.bb b/recipes/wifistix/wifistix-modules_5.0.16.p0.bb
new file mode 100644
index 0000000000..26a4c11a6c
--- /dev/null
+++ b/recipes/wifistix/wifistix-modules_5.0.16.p0.bb
@@ -0,0 +1,58 @@
+# FIXME, consider using kernel staging directory instead of KERNEL_SOURCE which is
+# located in the work directory. see module.bbclass
+
+DESCRIPTION = "Linux Driver for Marvel 88W8385 802.11b/g Wifi Module used in Gumstix daughtercards"
+SECTION = "base"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.gumstix.com"
+LICENSE = "GPL"
+RDEPENDS = "kernel (${KERNEL_VERSION})"
+DEPENDS = "virtual/kernel"
+PR = "r0"
+
+SRC_URI = "http://files.gumstix.com/cf8385-5.0.16.p0-26306.tbz \
+ file://wifistix.conf \
+ file://mcf25 \
+ file://marvell-devicename.patch;patch=1 \
+ file://marvell-devicetable.patch;patch=1 \
+ file://marvell-gumstix.patch;patch=1 \
+ file://sbi-no-inline.patch;patch=1 \
+ file://2.6.17-new-pcmcia-layer.patch;patch=1 \
+ file://bad-cast.patch;patch=1 \
+ file://sk_buff.patch;patch=1 \
+ file://struct-changes.patch;patch=1 \
+ file://no-more-config-h.patch;patch=1 \
+ file://realtime-kernel.patch;patch=1 \
+ file://install-properly.patch;patch=1 \
+ file://fix-essid-truncation.patch;patch=1"
+
+S = "${WORKDIR}/src_cf8385"
+
+inherit module-base
+
+EXTRA_OEMAKE = 'CONFIG_GUMSTIX=y CONFIG_DEBUG=n KVER=2.6 \
+ KERNELDIR="${KERNEL_SOURCE}" ARCH="${TARGET_ARCH}" \
+ CC="${KERNEL_CC}" EXTRA_CFLAGS="${CFLAGS}" \
+ INSTALL_MOD_PATH="${D}"'
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake
+}
+
+do_install() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake install
+
+ install -m 0755 -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 ${WORKDIR}/wifistix.conf ${D}${sysconfdir}/modprobe.d/wifistix.conf
+ install -m 0755 -d ${D}${sysconfdir}/modutils
+ install -m 0644 ${WORKDIR}/mcf25 ${D}${sysconfdir}/modutils/mcf25
+}
+
+FILES_${PN} = "${base_libdir}/modules/"
+FILES_${PN} += "${sysconfdir}/modprobe.d/"
+FILES_${PN} += "${sysconfdir}/modutils/"
+CONFFILES_${PN} = "${sysconfdir}/modprobe.d/wifistix.conf"
+CONFFILES_${PN} += "${sysconfdir}/modutils/mcf25"
+