aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/x-load
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2010-09-11 21:19:56 -0700
committerKoen Kooi <koen@openembedded.org>2010-10-12 16:30:14 +0200
commite4fd90fc53243e330e0cfbae6d1b17f5639f7baa (patch)
tree5155e24bca5e8abc51400cccda85e45e0a020543 /recipes/x-load
parentc51cc770389d6cc05555416b616fc90a6673c53e (diff)
downloadopenembedded-e4fd90fc53243e330e0cfbae6d1b17f5639f7baa.tar.gz
x-load: Add recipe to build from sakoman.com x-load repository
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/x-load')
-rw-r--r--recipes/x-load/x-load-sakoman_git.bb15
-rw-r--r--recipes/x-load/x-load.inc3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/x-load/x-load-sakoman_git.bb b/recipes/x-load/x-load-sakoman_git.bb
new file mode 100644
index 0000000000..b2c0e92b97
--- /dev/null
+++ b/recipes/x-load/x-load-sakoman_git.bb
@@ -0,0 +1,15 @@
+require x-load.inc
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/x-load-sakoman-git/${MACHINE}"
+
+PV = "1.44ss+${PR}+gitr${SRCREV}"
+
+SRCREV = ${AUTOREV}
+SRC_URI = "git://www.sakoman.com/git/x-loader.git;branch=master;protocol=git"
+
+SRCREV_omap4430-sdp = ${AUTOREV}
+SRC_URI_omap4430-sdp = "git://dev.omapzoom.org/pub/scm/bootloader/x-loader.git;branch=omap4_dev;protocol=git"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes/x-load/x-load.inc b/recipes/x-load/x-load.inc
index 0699c011ab..553ef58f33 100644
--- a/recipes/x-load/x-load.inc
+++ b/recipes/x-load/x-load.inc
@@ -18,6 +18,7 @@ XLOAD_USB_SYMLINK ?= "x-load-usb-${MACHINE}.bin"
MLO_IMAGE ?= "MLO-${MACHINE}-${PV}-${PR}"
MLO_SYMLINK ?= "MLO-${MACHINE}"
MLO_SYMLINK_NOMACHINE ?= "MLO"
+XLOAD_LOAD_ADDRESS ?= 0x40200800
do_compile () {
unset LDFLAGS
@@ -29,7 +30,7 @@ do_compile () {
}
do_install () {
- signGP ${S}/x-load.bin
+ signGP ${S}/x-load.bin ${XLOAD_LOAD_ADDRESS}
install -d ${D}/boot
install ${S}/x-load.bin.ift ${D}/boot/${MLO_IMAGE}