aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-data
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xorg-data
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xorg-data')
-rw-r--r--recipes/xorg-data/xbitmaps_1.0.1.bb6
-rw-r--r--recipes/xorg-data/xcursor-themes_1.0.1.bb7
-rw-r--r--recipes/xorg-data/xkbdata_1.0.1.bb7
-rw-r--r--recipes/xorg-data/xorg-data-common.inc14
4 files changed, 34 insertions, 0 deletions
diff --git a/recipes/xorg-data/xbitmaps_1.0.1.bb b/recipes/xorg-data/xbitmaps_1.0.1.bb
new file mode 100644
index 0000000000..6e5d7fe5ba
--- /dev/null
+++ b/recipes/xorg-data/xbitmaps_1.0.1.bb
@@ -0,0 +1,6 @@
+require xorg-data-common.inc
+
+DESCRIPTION = "Common X11 Bitmaps"
+LICENSE = "MIT"
+DEPENDS += "libxmu"
+
diff --git a/recipes/xorg-data/xcursor-themes_1.0.1.bb b/recipes/xorg-data/xcursor-themes_1.0.1.bb
new file mode 100644
index 0000000000..1107d08da9
--- /dev/null
+++ b/recipes/xorg-data/xcursor-themes_1.0.1.bb
@@ -0,0 +1,7 @@
+require xorg-data-common.inc
+PE = "1"
+
+DEPENDS += " libxcursor xcursorgen-native"
+
+FILES_${PN} += "${datadir}/icons"
+
diff --git a/recipes/xorg-data/xkbdata_1.0.1.bb b/recipes/xorg-data/xkbdata_1.0.1.bb
new file mode 100644
index 0000000000..9ab3729bc5
--- /dev/null
+++ b/recipes/xorg-data/xkbdata_1.0.1.bb
@@ -0,0 +1,7 @@
+require xorg-data-common.inc
+PE = "1"
+
+RDEPENDS = "xkbcomp"
+
+FILES_${PN} += " /usr/share/X11/xkb"
+
diff --git a/recipes/xorg-data/xorg-data-common.inc b/recipes/xorg-data/xorg-data-common.inc
new file mode 100644
index 0000000000..46b14d73af
--- /dev/null
+++ b/recipes/xorg-data/xorg-data-common.inc
@@ -0,0 +1,14 @@
+HOMEPAGE = "http://www.x.org"
+SECTION = "x11/data"
+LICENSE = "MIT-X"
+
+XORG_PN = "${PN}"
+
+SRC_URI = "${XORG_MIRROR}/individual/data/${XORG_PN}-${PV}.tar.bz2"
+S = "${WORKDIR}/${XORG_PN}-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}