aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-util
diff options
context:
space:
mode:
authormd <md@freiheit.com>2009-06-08 19:33:12 +0200
committermd <md@freiheit.com>2009-06-08 19:33:12 +0200
commit01c73184ab8a1c8515b426e24e5ee80e238f8365 (patch)
treefdd2a4580acdcac3ab329c47ed3ab4e4d9563ba9 /recipes/xorg-util
parenta9a408c12539e4bb6679563ac8da28c32aa41f3a (diff)
downloadopenembedded-01c73184ab8a1c8515b426e24e5ee80e238f8365.tar.gz
xorg-util: use the cross compiler instead of gcc in configure scripts
- the macro code provided for xlibs is not usable for cross-compiling as for determining the compiler version simply the `gcc' command is used - instead, we now use $CC
Diffstat (limited to 'recipes/xorg-util')
-rw-r--r--recipes/xorg-util/util-macros-1.2.1/cross-compiler-for-checking.patch11
-rw-r--r--recipes/xorg-util/util-macros_1.2.1.bb6
2 files changed, 17 insertions, 0 deletions
diff --git a/recipes/xorg-util/util-macros-1.2.1/cross-compiler-for-checking.patch b/recipes/xorg-util/util-macros-1.2.1/cross-compiler-for-checking.patch
new file mode 100644
index 0000000000..c646ffff5b
--- /dev/null
+++ b/recipes/xorg-util/util-macros-1.2.1/cross-compiler-for-checking.patch
@@ -0,0 +1,11 @@
+--- util-macros-1.2.1/xorg-macros.m4.in-orig 2009-06-08 13:49:09.000000000 +0200
++++ util-macros-1.2.1/xorg-macros.m4.in 2009-06-08 13:51:28.000000000 +0200
+@@ -445,7 +445,7 @@
+ CWARNFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes \
+ -Wmissing-declarations -Wnested-externs -fno-strict-aliasing \
+ -Wbad-function-cast"
+- case `gcc -dumpversion` in
++ case `$CC -dumpversion 2>/dev/null` in
+ 3.4.* | 4.*)
+ CWARNFLAGS+=" -Wold-style-definition -Wdeclaration-after-statement"
+ ;;
diff --git a/recipes/xorg-util/util-macros_1.2.1.bb b/recipes/xorg-util/util-macros_1.2.1.bb
index 4775fc6901..ddf8874a3b 100644
--- a/recipes/xorg-util/util-macros_1.2.1.bb
+++ b/recipes/xorg-util/util-macros_1.2.1.bb
@@ -1,5 +1,11 @@
require xorg-util-common.inc
+# Version 1.2.1 uses plain `gcc' for checking the compiler version.
+# Instead, the cross compiler must be used. Whenever upgrading to
+# a new version, please recheck for this problem, otherwise it breaks
+# builds with older gcc versions!
+SRC_URI += " file://cross-compiler-for-checking.patch;patch=1"
+
DESCRIPTION = "X autotools macros"
PE = "1"